2

I have Ubuntu installed on Windows 10 in the Windows Subsystem for Linux (WSL) and I am getting this problem whenever I run snap install <package> or snap list.

Has anyone had a similar error?

Steps to reproduce:
1. Install Ubuntu on Windows 10 WSL
2. sudo apt update
3. sudo apt install snapd
4. snap list (or) snap install ffsend

NB: I have also tried sudo snap list and it returns the same error.

1

Snap requires the "System and Service Manager" systemd which is a missing piece in WSL. Right now snap is not supported in WSL.

When running the command snap install htop I receive the following info:

Interacting with snapd is not yet supported on Windows Subsystem for Linux. This command has been left available for documentation purposes only.

I am running Ubuntu 18.04 with WSL on Windows 10 version 1809 build 17763.379.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.