0

Message goes "There was a problem during the CUPS operation: 'client-error-not-possible'."

I follow a protocol that I used on Ubuntu 16 many times, but now I reinstalled to Ubuntu 18. I start from running the command "system-config-printer" from a terminal window.

Click on "Add printer" --> "Network printer" --> "Windows printer via SAMBA". Then tick "Set authentication details now". I provide my name and password. - Click on "Forward". Then you will see a message about "Searching for drivers", wait until a dialog box is shown. Choose "Provide ppd", browse to the ppd -file that I fetch from a local list.

0

I don't know how to answer your question, because I had the same problem, I've just solved it, however I've not clear how I managed to do it.

First of all, I'm working with VMs. I think it should work with your systems, but who knows...

Well, as far as I know it was supposed to be an issue / bug with cups in Ubuntu 18.04 LTS. It's supposed to be fixed in new version of cups, as you may read at the end of the posts. So, what I did, after a lot of reading and touching here and there was installing the las version of cups in one of my Ubuntu 18.04.

Here I was, with cups 2.2.7-1ubuntu2.3. And it works!. I tried to do the same in other VM with Ubuntu.. but I found something weird, there was no entry in the repositories for cups 2.2.7-1ubuntu2.3. There were only the 2.2 versión... so I couldn't update :(. However, I tried to do all the steps just in case it worked, and It did!

The difference between the two systems is the kernel version. The one with cups updated to 2.2.7-1ubuntu2.3 has a 4.15.0.-29 kernel. The other one a 46.

Try to update you cups, just in case. I hope it will help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.