0

I worked on a project without problem but since I upgraded to 18.04, when I try to use git it prompts a pop-up reading "Enter password to unlock the private key. An application wants access to the private key 'loke@computer', but it is locked".

The problem is that my ssh key doesn't have a password. I can cat it or open it in gedit for instance without my root password.

I still tried using my root password in the pop up, as well as leaving it blank, clicking cancel and trying other passwords but nothing is working and I still can't use git.

I tried this but the first command gave me this error:

Error setting value: Can't overwrite existing read-only value: Value for `/apps/gnome-keyring/daemon-components/ssh' set in a read-only source at the front of your configuration path

and the second command didn't return anything but didn't change my situation either.

So far all the solutions I saw about closing this pop up is to delete your ssh key password, but what do I do if I don't have one to begin with?

1

As I couldn't find a fix for this I decided to go around it by replacing my ssh keys altogether, and my problem disappeared.

I created a new set of keys, overriding the old ones, and uploaded those to my BitBucket, and when I tried again the password prompt didn't appear.

So it definitely looks like a bug, as neither the old keys nor the new ones had a password, and yet they behaved differently?

Note: in the Password and Keys settings, when I clicked Change Passphrase on the old keys it also asked for a password which didn't exist, whereas on the new keys it's just asking me if I want to set a new password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.