1

I found a weird issue in Ubuntu 18.10. The issue was caused by my error, but it led to a situation that I couldn't figure out how to recover from, and I'm curious if anybody here has ideas about what happened. (I later figured out my mistake, so this is really more of a theoretical inquiry.)

I have a Cisco USB console cable. It contains an FTI USB-to-serial adapter. When I plug it in, I can see in dmesg that it is recognized and /dev/ttyUSB0 is created. If I try to connect to this device with the wrong baud rate, it freezes up my Bluetooth keyboard! I.e. the OS is still running, I can still use the mouse and interact with it, but they keyboard won't produce any output. Even if I switch to another application using the mouse, the keyboard just won't do anything. I tried plugging in a USB keyboard and that won't respond either. I tried Ctrl+C, Ctrl+Z, and ~., but nothing responded. I couldn't even switch to a console to kill the cu process.

I tried this with both cu and minicom and both had the same effect. I ended up rebooting the machine both times to recover.

Any idea what was causing this behavior? I eventually realized that I was using the wrong baud rate (should be 9600 for my Cisco device) and now everything is fine, but I'm still curious what the root cause is and whether this is something I should file a bug for or if its "expected" behavior.

  • I am having the same issue with Arduino connected over serial. I am using correct baud rate. – Andrew Romanenko Nov 1 '19 at 8:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.