2

This maybe a stupid question, with easy fix. But I searching around to no avail.

I'm unable to change docky configuration, I tried opening the docky setting on the dock, but the option to make it hide was grayed out.

Docky settings

How would I modify the option ? Or is the Docky project really dead, before Docky I'm using Plank but it doesn't have animation. If Plank has animation, I would stay with that.

FYI: I install it with sudo apt install docky

  • Please mention the version of Lubuntu. And the last release seems to be from 2015-09-02 according to the Launchpad page. – DK Bose Mar 13 at 9:50
  • I use Lubuntu 18.04 – Emmet Mar 13 at 9:56
  • One of Docky's developers is keeping Plank development going: launchpad.net/~ricotz/+archive/ubuntu/… – DK Bose Mar 13 at 9:58
  • I used Plank before and it's good, but their dock is static, I want it to have animation. – Emmet Mar 13 at 10:00
  • There's a small animation at the time of loading an appllcation: youtu.be/FPSIh2VRrvY?t=290. I guess you want an animation when you hover over an icon in the panel. I don't use Docky or Plank and so I hope someone else comes along to help! – DK Bose Mar 13 at 10:11
1

To make Plank show animation on hover with Compton as the compositor

Open a terminal and run plank --preferences

You'll get a window looking like this:

Plank preferences to set animation on hover

You can adjust the value of Icon zoom to suit your needs.

Compositing

  • Lubuntu 18.04 comes with its own compositor called Compton which you can start from Menu > Accessories > compton.
  • There's also a very nice interface for adjusting Compton's settings. This GUI is called Window Effects and is found under Menu > Preferences > Window Effects.
  • Once you start Compton make the changes you want in Window Effects, go to Menu > Preferences > Default applications for LXSession and in the window that opens, add Compton to your Autostart as in the image below.

Setting Compton to Autostart

  • Is compton Lubuntu default apps ? I never noticed it ! – Emmet Mar 13 at 11:58
  • I already done what you did, but Plank doesn't enlarge when hover. – Emmet Mar 14 at 13:01
  • 1
    xD my bad, I changed the configuration and it worked perfectly now. Thanks Dk – Emmet Mar 14 at 13:05
  • Plus, compton needs to run. I was about to upload a small video to YouTube so that you could see it working! – DK Bose Mar 14 at 13:10
  • 1
    Plank now behaves the want I want, thank you so much. – Emmet Mar 14 at 13:13
2

After searching around, it turns out Docky require compositing in order to work properly, and compositing reside in Compiz window manager.

So I tried to find the workaround, and found the fix:

sudo apt install xcompmgr

or

sudo apt install compton ###I USE THIS

Both will apply compositing, which enable Docky full capabilities.

Docky settings after compositing

However, there are price to pay. The compositing made Lubuntu desktop buggy, for example:

  • Desktop background only shows gray color.
  • Screen tearing
  • etc.

I guess Im gonna stick with Plank, the dock that works stable on Lubuntu without further hack.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.