0

Since a few days ago my computer is giving me a black screen when I boot it up. At first, I could still start it in recovery mode. All info I could find to fix it points to the graphics driver (in my case for AMD Radeon RX 480).

I tried to reinstall the amdgpu driver, but somehow it seems not to become active when checking: lsmod | grep -e amdgpu gives no output. Also lshw -c video shows no active driver. I tried with oibaf drivers, but with no effect. Then I tried setting 'quiet splash nomodeset' in sudo gedit /etc/default/grub. However, after that I can't login in recovery mode anymore either; I now get a quick flashing screen of my desktop background for a few seconds and then a black screen with a cursor. I can still open tty2 with Ctrl+Alt+F2.

Could someone point me in the right direction? I've searched for info, but am a bit lost now.

0

Problem solved. 'nomodeset' was the culprit. Removing 'nomodeset' from within recovery mode apparently did not register it in the settings. Pressing 'e' to edit '*Ubuntu' in the grub menu solved it and then I could save the change in 'etc/default/grub'. The computer works fine now with the drivers from the AMD website.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.