83

I have my PC hooked up to speakers and a monitor. In addition, it is hooked up to my Vizio 37' LCD Television. When I was on Windows 7, I could choose to output sound via HDMI. I have the choice in Ubuntu but no sound is outputted. Any Ideas? I don't know how to get system specs on Ubuntu so if you need them please tell me how to get them.

aplay -l output:

**** List of PLAYBACK Hardware Devices **** 
card 0: Intel [HDA Intel], 
device 0: ALC887 Analog [ALC887 Analog] 
Subdevices: 0/1 
Subdevice #0: 
subdevice #0 card 0: Intel [HDA Intel], device 3: ALC887 Digital [ALC887 Digital] Subdevices: 1/1 
Subdevice #0: subdevice #0 card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0 
11
  • I don't know how to provide any more data.
    – Michael
    Mar 13, 2012 at 18:12
  • At the very least we need to know what kind of sound card you're using: aplay -l Mar 13, 2012 at 18:14
  • Any simple to use programs I can use that can provide such information?
    – Michael
    Mar 13, 2012 at 18:29
  • Stupid me, Sorry about that. **** List of PLAYBACK Hardware Devices **** card 0: Intel [HDA Intel], device 0: ALC887 Analog [ALC887 Analog] Subdevices: 0/1 Subdevice #0: subdevice #0 card 0: Intel [HDA Intel], device 3: ALC887 Digital [ALC887 Digital] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0
    – Michael
    Mar 13, 2012 at 18:35
  • Have you checked that it's not muted in alsamixer? crunchbang is ubuntu derived and has a report of it being accidentally muted Mar 13, 2012 at 18:43

6 Answers 6

112

With the HDMI cable plugged in, run the following utility:

speaker-test --channels 2 --rate 48000 --device hw:0,3

(for others, the hw:x,y is x = card, y = device)

This just runs a sound test with static bouncing back and forth. Once it has played out of each speaker, hit Ctrl+c to stop it, and then check in your sound settings to see if the HDMI output is now listed under the internal device.

That was all I had to do to get it working. If it doesn't work for you, check out this tutorial for upgrading alsa to the ppa version.

5
  • 35
    This is ridiculous, but works admirably. Thanks. Mar 24, 2013 at 2:50
  • 3
    Upgrading alsa + installing pavucontrol as suggested by @gsdej 's post (instead of the speaker test) worked for me
    – nariknahom
    Oct 28, 2013 at 11:46
  • This did not work for me. The install failed. please see askubuntu.com/questions/512482/hdmi-audio-not-working-on-tv
    – faizal
    Aug 17, 2014 at 11:12
  • Thanks for this, I had tried pavucontrol before and it still wasn't playing through the TV. After running this little test, it suddenly started playing...wierd
    – smac89
    Dec 29, 2014 at 1:08
  • 1
    // , This works, but firefox is still not using HDMI, while Chromium now does, on Ubuntu 16.04. Apr 9, 2017 at 23:07
82

You can try installing program "PulseAudio Volume Control" (sudo apt-get install pavucontrol)

In tab Configuration select profile mentioning HDMI.

The desktop sound output should immediately switch to HDMI.

9
  • 1
    Thank you, this worked for me on 12.10, Intel HD 4000. For me, HDMI was not listed as an output device in the system's sound settings. But once I selected the HDMI profile in the configuration tab of the "Pulse Audio Volume Control", sound through HDMI worked and HDMI was even listed as an output device in the standard sound settings. Bryan's approach didn't work for me.
    – Tobias
    Feb 28, 2013 at 22:14
  • This also worked for me - ALSA could see it but Ubuntu's desktop couldn't.
    – Tom Dalton
    Sep 10, 2013 at 18:54
  • 1
    There's no pavucontrol on 14.04 Jun 5, 2014 at 1:00
  • 1
    No HDMI profile in the Configuration tab for me.
    – cboettig
    Dec 3, 2014 at 20:20
  • 1
    It works for me! Ubuntu 16.04
    – Ponsuyambu
    May 28, 2017 at 10:36
4

I have had similar problems, and all the forums I could find were talking about PulseAudio and AlsaMixer. None of those solutions worked for me.

I finally found my solution in updating my Graphic Cards driver from which the HDMI cable was connected following the steps here.

You might not have the same grapic cards or any but you might give it a try to update your driver.

4

Install GNOME alsa mixer which is in the universe repository (activate the universe repository in your software sources by running Software & Updates and insuring the 2nd box from the top is checked) then Install via Ubuntu software.

gnome-alsamixer

run it and you'll see a screen like this:

gam

unmute everything by clearing the mute checkboxes , then check the IEC958 checkbox.

4
  • 6
    While this may theoretically answer the question, it is too vague to be useful. Please expand it to include the steps needed to accomplish what you are suggesting. While experienced user may know how to do this, new user likely will not; it needs to be useful to all users.
    – TrailRider
    Aug 18, 2013 at 16:40
  • 5
    What's vague about it? I installed GNOME alsa mixer from the ubuntu store, ran it, and there was a checkbox labeled IEC958.
    – AaronF
    Oct 3, 2015 at 19:09
  • Use m key to un/mute. MM under a volume bar means muted, highlighted OO means enabled.
    – anps
    Dec 24, 2015 at 21:42
  • 3
    What it you have 3 times IEC958 and no IEC958PCM? May 13, 2017 at 11:29
2

For me the things that worked was killing the pulseaudio daemon via the following command

pulseaudio -k

I got inspired from this link.

1

I have Debian with LXDE but this may apply to you in other cases.

Open PulseAudio Volume Control

enter image description here

Initially I thought I needed to upgrade something because I could not see HDMI here

enter image description here

But after going to Configuration and selecting a profile with HDMI

enter image description here

You can go to Output and see there your HDMI port. Now the sound goes through the HDMI cable. Nothing to install / update / tweak (in my case).

enter image description here

1
  • OMG how is this how it works. Sure HDMI settings need to be changed but why is there no separate HDMI output audio device jeez May 8 at 18:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.