0

I've installed ubuntu 18.04 lts alongside windows 10. I partitiond a disk of 80 GB on windows. Then i booted ubuntu from a usb pendrive, and did the following steps. 76GB partition for the root system, logical, ext4 system. Then another 4GB for swap area. When I wanted to continue, it said:

No partition detected for EFI, your system might not boot. Please create a partition for the EFI or continue at own risk.

So I went back and created a EFI System type partition with 200MB as recommended. Then the installation went properly, but after it, when the system restarted the boot failed with the following message

Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key.

What I tried: disabling the UEFI/Legacy mode. My boot order: 1)HDD 2)CD/DVD 3)PXE network

I also did a boot info with the log at: boot log

I didn't find any other suggestions with this topic, so I'm asking for your help. I don't want to loose data and programs on win10 if it's possible, but I would definitely like to have a dual boot option with Ubuntu being the other OS

EDIT: So I discovered in GParted that the boot flag from sda1 ntfs (Win 10 boot) came off, so I added it. Now I can access WIN 10, but still not Ubuntu.

1

While I do not know the detailed list of events that led to the issue, I believe the root cause is that your Windows installation boots in legacy (BIOS) mode, and your Ubuntu installation is using UEFI. The UEFI/Legacy option that you tried disabling, stands for BIOS mode. In my experience, different boot modes don't work well together, you should use the same for both.

There are two ways to achieve that.

One is that you reinstall Ubuntu in legacy mode. I believe that the installer pendrive is able to boot from both UEFI and BIOS mode, and that it installs Ubuntu so that it can boot the same way as you booted to the installer. Consequently you should turn the UEFI/Legacy boot mode back on, and boot the installer in legacy mode, get rid of the EFI partition and install Ubuntu as you originally intended. Then after you try to boot Ubuntu, GRUB should detect the Windows installation and offer you to boot into that.

The other way would be to reinstall Windows in UEFI mode. As far as I know, Windows boot mode is entirely dependent on the type of the partition table, which can be MBR (labeled as dos in fdisk) or GPT. When you install it on a drive with an MBR partition table, it will boot in BIOS mode, which is your case currently, but when you install it on a drive with a GPT partition table, it will boot in UEFI mode. Thus, to do this you would have to create a new partition table (causing you to lose all data on the drive), install Windows 10 then install Ubuntu. In both cases you should make sure that you boot into the pendrive in UEFI mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.