The title is pretty self explanatory, but I'll try to write as many details as possible, because this problem has been driving me nuts for the past few hours.

Yesterday, I installed 18.04.2 LTS on my personal computer, the minimal version.

Today, I tried accessing Netflix using Google Chrome, version 72.0.3626.121 (Official Build) (64-bit) and Firefox, version 65.0.1 (64-bit).

However, no matter what I do, I keep getting this error:

Netflix Site Error. We were unable to process your request. Please go to the Netflix home page by clicking the button below.

Obviously, I did my best to search this issue and found a few answers, which unfortunately, did not fixed my problem.

Here are the things that I've tried:

As far as I know, Netflix should work natively on Google Chrome. In my case, it doesn't. As I was writing, I quickly installed Opera and tried accessing Netflix, but ran into the same issue.

I'm running out of ideas. Any help would be greatly appreciated.

Later edit After some updates, Netflix has started working again. No idea why though or if the updates had anything to do with it.

  • It's probably a Netflix problem... but you can try this... boot to a Ubuntu Live DVD/USB, install Chrome, try Netflix. Report back. – heynnema Mar 12 at 15:33
  • @heynnema, thanks for the suggestion, but for some reason, this issue has been resolved. Yesterday, after receiving a couple of updates (including core), Netflix started working again on all browsers. – awildmudkip Mar 18 at 18:40
  • You may answer your own question and accept it to get this marked as "solved". – ubfan1 Mar 18 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.