0

Dell Precision 7520 Ubuntu 18.04 laptop with xrdp installed. Self built Windows 10 makes RDP Remote Desktop Protocol connection to Ubuntu machine on local network. Exactly at 30 minutes connection is dropped, Ubuntu goes in Suspend mode. Hit keyboard on Ubuntu machine and no problem reconnecting. On Ubuntu 18.04 Settings->Power->Suspend & Power Button Automatic Suspend is set to 45 minutes on Battery Power. When connected through Win10 RDP the Settings->Power->Suspend & Power Button in not visible. Dell Bios Power Management->Wake on LAN/WLAN is set to Wake-On-LAN Any ideas on how to override automatic suspend setting when connecting from Win10 RDP

0

Ok the situation is Ubuntu 18.04 still drops the network connection exactly after 30 minutes. One workaround is "sudo systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target". (Sends everything to /dev/null symlink.) This for some reason only drops the first 30 minute disconnection from Ubuntu. Of course all data is lost since nothing is saved after the connection is dropped. Then after logging back on the 2nd time through Win 10 RDP no more drops. But this is only a workaround. I still need to know how to stop Ubuntu 18.04 from dropping the network connection after 30 minutes.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.