1

I have the problem that xfce4-notifyd.service is not starting when I login to my machine (Ubuntu 18.04.2 with XFCE).

I tried the solution mentioned here but still no change in behaviour: https://forum.xfce.org/viewtopic.php?id=12213

Currently I have to manually start it each time after login is finished - how can I debug / troubleshoot this?

Thanks!

0

I solved the problem:

Using "journalctl" I checked the logs again and saw this message that got my attention:

org.kde.knotifications: WaitForName: Service was not registered within timeout

So I checked "/usr/share/dbus-1/services" for a file named "org.kde.knotifications".

I found the file and renamed it:

sudo mv org.kde.plasma.Notifications.service org.kde.plasma.Notifications.service.bak

After a reboot everything works fine again

0

Run journalctl -f to follow logs and then try notify-send test from another terminal. If notify-send hangs and after a timeout you see the following error message in journalctl:

org.freedesktop.Notifications[12345]: org.kde.knotifications: WaitForName: Service was not registered within timeout

The issue may be that you have plasma-workspace installed. If you don't need it anymore, remove it (sudo apt-get remove plasma-workspace), mind that this removes packages like plasma-desktop. Notifications should work again after removing this package.

See this bug report for details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.