I can do screencasts by pressing ctrl+alt+shift+r, but I get no sound when I view the videos, I've check my built in mic and headset, they both work on skype and such, I just can't record sound with the gnome built in screencasting. Also, when I open the videos in movieplayer they are in mute by default and there's nothing the the preferences I can find to change that.

Any help would be awesome!


I found a solution that worked in my case. Open terminal Ctrl+Alt+T and run the following command:

gsettings set org.gnome.shell.recorder pipeline "queue ! videorate ! vp8enc quality=8 speed=6  threads=%T ! mux. pulsesrc ! audio/x-raw-int ! queue ! audioconvert !
vorbisenc ! mux. webmmux name=mux"

OR do it with dconf Editor, and then you'll have to modify the file: /usr/share/gnome-shell/js/ui/main.js in line 110 (I think) replace:




After that, you can decide what stream of audio (internal or external) you want in recorder installing pavucontrol.

I hope that this would help.

  • Almost! It still doesn't stop recording audio when I hit ctrl + alt + shift + r the second time. Thanks for the help though : ) – Costa Oct 19 '12 at 16:58
  • Now it doesn't work at all. New laptop, new OS: thinkpad x1 carbon, Ubuntu Gnome 13.10. The main.js file is different. It doesn't have the word pause anywhere in it. Also, this time around, changing the recorder string from the default just breaks the recorder, no function at all. Any ideas? – Costa Jan 16 '14 at 18:37

Actually, you can record audio. You just need to re do the pipe in the config:

Paste this into a console and that should do the trick:

gsettings set org.gnome.shell.recorder pipeline "queue ! videorate ! vp8enc quality=10 speed=2 ! mux. pulsesrc ! audio/x-raw-int ! queue ! audioconvert ! vorbisenc ! mux. webmmux name=mux"
  • Hmmm that seems to work, except it never finishes. It keeps recording audio even after I press ctrl + alt + shift + r again. I think it's still recording now. – Costa May 20 '12 at 0:11
  • 1
    On Fedora 19, adding this line will turn ctrl+alt+shift+r unresponsive; when removed it works again. Tried on two different machines. – That Brazilian Guy Dec 4 '13 at 17:40
  • This does not work anymore (15.10); No such schema 'org.gnome.shell.recorder' – Yanick Rochon Oct 12 '15 at 8:08

I never heard that gnome-shell screencast record video AND audio.

In this case you can record with an another software in background or choosing an another application like recordMyDesktop.


  • It doesn't record audio? I'm sorry I assumed it recorded audio. Is there a plan to include this at any point in time? – Costa Mar 19 '12 at 1:37

EasyScreenCast (extension)

This extension simplifies the use of the video recording function integrated in gnome shell, allows quickly to change the various settings of the desktop recording.


Active Shortcut: Super+E


NOTICE: If an error occurs during the update is recommended to reload GNOME Shell (Alt + F2, 'r') and reload the extension's installation page.

  • Start recording button doesn't do anything. Shortcut key as well. I'm on Gnome on Ubuntu 18.04. – Costa Feb 20 '19 at 0:50
  • Did you try this? "If an error occurs during the update is recommended to reload GNOME Shell (Alt + F2, 'r') and reload the extension's installation page." – Cesar Devesa Mar 2 '19 at 16:24

According to Ubuntu Buzz - Unofficial Ubuntu blog you cannot record audio with build-in gnome-shell screencast.

This is one of great feature which is owned by the Gnome Shell, but one notable thing you should know is, you can't record any voice using this, you will get silent video

Source: Ubuntubuzz.com

I searched and found another source. I don't know if this can be considered as more "Official". A relevant question to yours , about audio

On a related note, is it planned/allowed to be able to record audio as well as video?

answered like this

For sound you could just open sound recorder and start talking.

Source: Gnome-shell development

Of course all other answers here (with dconf editor & pipeline) are workarounds you can use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.