I am running Ubuntu 11.10 with '2' Nvidia GTS-250 GPU's. I am trying to get TwinView to work. Currently I have everything working as far as both screens are on and I can drag between them and use workspace switcher fine. I am having a few different issues, my assumptions lead me to believe all of them are related to the TwinView display. The issues I am having are as follows:

  • Once logged in an error is displayed stating: "Could not apply the stored configuration for monitors. none of the selected modes were compatible with the possible modes: Trying modes for CRTC 351 CRTC 351: trying mode 3840x1200@50Hz with output at 1920x1080@50Hz (pass 0) CRTC 351: trying mode 3840x1200@50Hz with output at 1920x1080@50Hz (pass 1)
    • At this point all system and application windows & font are really large including the desktop text. All I do is close out of this error. And the font and window size issues are gone. Seems like the display quickly refreshes when I close out of this error.(Not sure what happens that quick fixes the issue, until I need to logout and back in of course.)
  • Any videos streamed through any browser do not work fully. It lags and chops up a bit. Not sure if this is a flash issue or not. I currently have flashplugin-installer installed from the software center. I have read about an issue with the current version of flash and "Gnash" causing issues. Double checked, I do not have Gnash installed.

I'm gonna try and think ahead here of any possible file or setting anyone would need to see to help with this issue: I posted my current xorg.conf file and results of xrandr command here:


My setup consits of the 2 Nvidia GTS-250 GPU's. Both monitors are connected to the same(first) GPU card. The monitors in use are an LG-47 LED and a Samsung-24 LCD. Just a standard left(default-LG)display --> right(secondary-Samsung)display

  • The Nvidia driver I have installed is from the Additonal drivers panel, The Nvidia accelerated graphics driver(version current)[Recommended]. The other option listed is the (post-release updates)(version current-updates).

I have a fully updated OS with nothing out of the ordinary software running outside of compiz. I never had these issues before I setup Twinview but I do vaguely remember having to uninstall and reinstall flash around when I setup TwinView.

Just to provide some more detail: If I attempt to go into displays, It only detects 1 large unknown monitor with a resolution of 3840x1200 and wont allow for any changes(I thought this was normal being that I was led to believe to only utilise the nvidia x-server settings. The X server settings GUI shows the following(relevant info):

Operating System: Linux-x86_64 Nvidia Driver Version: 295.20

XServer Display Config: (GUI) Shows the LG and Samsung monitors in the correct positions.

  • Configuration: TwinView
  • Resolution: Auto
  • Position: Absolute (only difference is the samsung display position is: +1920+0)
  • Panning: LG-1920x1080 Samsung-1920x1200

I hope I have explained this well enough in detail. I'm honestly not worried about the display issues and error message once logged in. Easy enough to just close it out and act like it doesn't happen(unless you believe they are somehow related). The only reason I included all the details with that is I do believe the issues are related. For the past 2 days I have researched issues online and found a ton of workarounds for Twinview to work display properly(assuming this is causing the flash video issues.) I have followed a few different tutorials for Twinview and Nvidia drivers all of which didn't correct the issue or left me unable to boot(Had to boot to recovery console and restore old versions of files I modified during the various tuts to allow boot to desktop) (Good thing I backed them all up 1st :))

My main concern is to allow videos to stream and play properly without lag and screen chop/flickering.

Thanks for all the help. Let me know if you need me to provide any more info, I'll be here waiting the whole night =)

UPDATE: Uninstalled and reinstalled the same flash-plugin I had installed before from the software center. Still the same issues. (Starting to think it may not be a flash issue. I feel silly saying this but, The only fix I know with flash is to uninstall and reinstall lol)

  • point up for question. My GTX460 was burnt with playing fullscreen flash. Similar configuration and OS but without TwinView. Different versions of Flash bring different results. Adobe exorcists repudiate from Linux ))) Yesterday I found that installing "adobe-flashplugin" package calls removing Firefox. So for now it is mutually excluding things :D – swift Mar 18 '12 at 3:46

I had the "Could not apply the stored configuration for monitors. none of the selected modes were compatible with the possible modes..." as well. Somehow that error happend to override my symbol and font settings. Really strange. But anyhow, here's how I fixed it:

open dconf-editor

navigate to /org/gnome/settings-daemon/plugins/xrandr

untick active

This will obviously disable the xrandr-plugin. Why or how this is related to our problem I can't tell, but it definately fixed it for me. Hopefully, it will work for you as well.

Good luck!

  • 1
    I know this is late in response but I was unfortunately away from my desktop setup for awhile due to moving. You sir are a gentleman and a scholar. Installed dconf-editor navigated to what you said and a quick restart. Viola, problem with the icons and display configuration errors are fixed. Thank you so much for sharing the fix you discovered! – ityler22 Jul 15 '12 at 2:05
  • Thank you for your kind words, I'm glad it helped. Good day to you, Sir! – FuzzyQ Jul 15 '12 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.