5

I want to change the name of my partition so that I can change the directory from the terminal using the changed name. The current path to the partition is /mnt/8C5442D35442C026 which is long and I cannot remember it. I tried to change the path using GParted, also tried renaming the partition (or rather its bookmark) but to no avail.

How can I achieve it? I am running Ubuntu 18.10 along with Windows 10. I want to be able to use that drive/partition on Windows as well.

Edit:

The output of cat /etc/fstab is

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=e8118874-6565-45c7-bab4-67ee65476e60 /               ext4    errors=remount-ro 0       1
/swapfile                                 none            swap    sw              0       0
/dev/disk/by-uuid/8C5442D35442C026 /mnt/8C5442D35442C026 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/3C5234155233D1FE /mnt/3C5234155233D1FE auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/7A7E1A557E1A0B11 /mnt/7A7E1A557E1A0B11 auto nosuid,nodev,nofail,x-gvfs-show 0 0
  • 1
    You should have successfully renaming the partition label using Gparted, what did go wrong may I ask? I've never encounter a problem before... – Johnny Mar 9 '19 at 15:13
  • edit your post and include the output of cat /etc/fstab – Carl H Mar 9 '19 at 15:14
  • Use Disks utility. – Pilot6 Mar 9 '19 at 15:17
  • @Emmet I changed the name to F: using GParted. It shows the name in File Explorer but not in the path. cd "F:" does not work in terminal. – Apoorv Potnis Mar 9 '19 at 15:20
  • 1
    Your question is unclear. Do you want to change the mountpoint, the name of the partition, or the name of the filesystem inside that partition? – Jörg W Mittag Mar 9 '19 at 16:19
7

You don't need to change the label, only the mountpoint. First, run sudo nano /etc/fstab and change this line:

/dev/disk/by-uuid/8C5442D35442C026 /mnt/8C5442D35442C026 auto nosuid,nodev,nofail,x-gvfs-show 0 0

To this:

/dev/disk/by-uuid/8C5442D35442C026 /mnt/myDisk auto nosuid,nodev,nofail,x-gvfs-show 0 0

Of course, you can change myDisk to whatever name you want. Then, create the directory:

sudo mkdir /mnt/myDisk

Next, either reboot or just unmount the partition and mount it again:

sudo umount /mnt/8C5442D35442C026
sudo mount /mnt/myDisk

Alternatively, you could always simply create a symlink pointing to the existing mountpoint:

ln -s /mnt/8C5442D35442C026 $HOME/myDisk

Now, you have the directory $HOME/myDisk and you can use that instead of /mnt/8C5442D35442C026.

  • I do add labels to all partitions, but more for the ones I do not mount in fstab or only use occasionally. I try to remember to add label when creating partition or reformatting partition with gparted, but otherwise will use Disks to add labels or command line. – oldfred Mar 9 '19 at 15:59
  • 1
    @oldfred remember that the labels are not related to the mount point. You can use any label you like and any mount point you like. The two don't need to be the same. – terdon Mar 9 '19 at 16:46
  • I know, I have labeled partition Data and mounted at /mnt/data and had confusion. But I have lots of partitions and only mount backup & data in fstab, so all other partitions get mounted by label when I may want to see it. – oldfred Mar 9 '19 at 16:54
0

As suggested by terdon in an another answer, we need to change only the mount point. This is achieved easily as suggested by dolzenko here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.