0

Computer Specs

Asus Zenbook UX433FN

i7-8565U

512GB PCIe NVMe, 16GB RAM DDR3

Nvidia MX150 (!)

Background

Just successfully installed Ubuntu 18.10 on my computer (specs above). Secure boot off, fast boot off. Used nomodeset parameter for both install and boot.

Dual boot Windows 10 UEFI.

Partitioned around 230GB for Ubuntu.

Used minimum install and option to install 3rd party drivers.

Problem

After booting up Ubuntu from said fresh install, stuck at black screen with blinking cursor.

Boot options: nomodeset (quiet splash or lack thereof doesn't make a difference)

Most of the solutions advise nomodeset but I already did that... Any help would be appreciated!

0

Solved, but not sure what helped to solve the issue. Did the following:

1) Added boot options: nomodeset acpi_iso="!Windows 2018"

> Still stuck at black screen

2) Used ctrl-alt-F2 to switch to TTY2 (and thus got terminal)

3) Downloaded proprietary Nvidia drivers as per https://www.cyberciti.biz/faq/ubuntu-linux-install-nvidia-driver-latest-proprietary-driver/:

$ sudo apt install nvidia-driver-390

4) Went back to TTY1 (ctrl-alt-F1) > Sadness.

5) Went back to TTY2 (ctrl-alt-F1) > Magic! Worked!

I have no idea what exactly solved the issue, whether it was acpi_iso or the Nvidia drivers, or both, though I suspect the latter made all the difference.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.