I've been trying to get remote desktop working with my installation of Ubuntu 18.04, but the toggle doesn't seem to stay on. I go to settings, then Sharing and switch the toggle to on, then I select Desktop Sharing and try to turn the second toggle on, but it keeps springing back to off.

My machine was recently upgraded from 14.04 to 16.04, and now to 18.04 as the OS recommended that I upgrade.


After giving cmak.fr's suggestion a try first thing this morning, I realised that the Networks box at the bottom of the dialog shows that no networks are selected. I definitely have a connections, so I'm wondering if this is where the root of the issue lies.

I've tried the suggestion here: Screen-Sharing "no network selected for sharing" problem in unity control center (18.04), but I still haven't been able to make it work through the dialog.

Screen Sharing dialog showing missing Networks list

  • 2
    Try to launch the vnc server manually from terminal and edit/paste the eventual errors - On 18.04 the vino vnc server is located here /usr/lib/vino/vino-server
    – cmak.fr
    Mar 9, 2019 at 9:10
  • Thanks @cmak.fr. I wasn't able to connect after this but that might be related to the client that I'm using. I did notice an issue, and I'm going to update my question with a screenshot that might explain the issue a little better. Mar 11, 2019 at 14:55

2 Answers 2


I just wanted to add that I ran into this after a recent install when I chose the minimal installation for Ubuntu. The vino-server package was evidently not installed. Because of this, the screen sharing cannot be enabled. I installed the vino-server package and then was able (after logout/login) to enable screen sharing.


I'm facing the same issue with my ethernet connection on Ubuntu 20.04. I ended up adding /usr/lib/vino/vino-server to my start-up applications.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .