8

I've recently done a fresh install of Ubuntu 18.10. I've experience an issue where the scroll function is not working properly after the system has been suspended. It's sluggish and slow, kinda like if it's only registering "half the scroll".

After a restart it works perfectly again. Any ideas?

EDIT: I found a solution that restarts the touchpad automatically via a script. Posted how to as answer! :-)

1
7

After several tries, I managed to find a solution and made it run automatically after reading this thread. I've only tested it on Ubuntu 18.10:

Basically, restarting the touchpad with these commands fixes it:

First run:

sudo modprobe -r psmouse

Then:

sudo modprobe psmouse

But.. I didn't want to have to write those commands after every suspend. So I setup a script running the commands above automatically everytime I resume from suspend

Run commands automatically after suspend:

1) Create script with commands (open Terminal and type)

sudo touch yourscriptname.sh

This will create the file in your home folder.

2) Edit script

sudo nano yourscriptname.sh

Paste this in and save the file:

#!/bin/bash

modprobe -r psmouse && modprobe psmouse

3) Move to your "system" folder

cd /etc/systemd/system

4) Create service:

sudo touch yourservicename.service

5) Edit service:

nano yourservicename.service

Paste this in and save it afterwards

[Unit]
Description=Run user script after suspend
After=basic.target suspend.target hibernate.target

[Service]
User=root
Environment=DISPLAY=:0
ExecStart=/home/yourusername/yourscriptname.sh

[Install]
WantedBy=basic.target suspend.target hibernate.target

6) Run chmod

sudo chmod +x /home/yourusername/yourscriptname.sh

7) Then run the following commands

systemctl daemon-reload

And:

sudo systemctl enable yourservicename.service

That should fix it!

6

Thinkpad Touchpad scrolling fixed (Permanently)!!!

First, go to the path and edit grub using any editor (run command using sudo).

Using vim editor: sudo vim /etc/default/grub

or

Using gedit editor: sudo gedit /etc/default/grub

Then, replace the existing line code in grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.synaptics_intertouch=0"

Then, save the file within the text editor.

Finally, update grub.

sudo update-grub
3
  • This instruction followed by a reboot worked for me (running 18.04 on T480) – leoybkim Jun 13 '20 at 22:19
  • Works for X240 on Linux Mint 20. – Simbamangu Oct 14 '20 at 7:28
  • works for Thinkpad P50 – shantanu Feb 20 at 18:04
1

just do the following

sudo gedit /lib/systemd/system-sleep/psmouse-refresh

and paste these

#!/bin/bash

# $1 is the state (pre or post)-sleep
if [[ $1 == post ]]; then
    sudo modprobe -r usbhid
    sudo modprobe -r psmouse
    sudo modprobe psmouse
    sudo modprobe usbhid
fi

save and done

0

Found here:

Hi, please remove psmouse.synaptics_intertouch=0 and comment out blacklist i2c_i801 in /etc/modprobe.d/blacklist.conf, and see if this helps.

That worked perfectly for my thinkpad

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.