0

I'm experiencing problems with UEFI and BIOS installations of Kubuntu 18.04 that popped up after installing a new Radeon VII vega.

1) Kubuntu installation in UEFI mode - the only available screen resolution during installation, and in the desktop, is 1024x768, which looks horrible on a 2560x1440 monitor. On the other hand, a BIOS mode installation can find all monitor resolutions. I think the Radeon VII firmware UEFI support is broken for Linux, and the installer defaults to a safe screen resolution.

Note that the Radeon VII shipped with no UEFI support, but bios 105 fixed it for Windows.

2) Minecraft in Kubuntu (in both UEFI and BIOS mode installation) runs extremely slow, only 2FPS. CPU usage is around 50%, with Ryzen 1800x. It's as though the CPU is doing all the work.

Dual boot with Win10 and Kubuntu UEFI mode installations seems to work, but there were some random problems with not booting. Right now I'm running both OSs in BIOS mode and dual boot works ok.

So far I have done the following, with no results.

  • flashed the Radeon vbios to 106 (latest as of 2-11-19)
  • Installed Padoka stable ppa

I also tried ubuntu upstream kernels 4.20 and 5.0. Both caused black screens during bootup, so I reverted to 4.18.

System: Gigabyte AB350 Gaming 3 mobo, 16 GB RAM, Ryzen 1800x, Radeon vega VII. The Kubuntu 18.04 installer was burned to USB drive using Rufus. It has a hybrid BIOS/UEFI mode which lets you select which to install.

I'm not expecting an immediate solution. Probably AMD is working on this. Has anyone has run into similar problems? I can't find anything on the net. Thanks!

1

I'm currently running a Radeon VII on ubuntu 18.04.
Using kernel 4.15.0-47-generic and amdgpu-pro-18.50-725072.
Try this:
Install kernel 4.15.0-47-generic

sudo apt-get install \
linux-image-4.15.0-47-generic \
linux-modules-4.15.0-47-generic\
linux-modules-extra-4.15.0-47-generic \
linux-headers-4.15.0-47-generic
sudo update-grub

Then download amdgpu-pro 18.50 from http://amd.com

wget --referer support.amd.com \
https://drivers.amd.com/drivers/linux/amdgpu-pro-18.50-725072-ubuntu-18.04.tar.xz 
tar xf amdgpu-pro-18.50-725072-ubuntu-18.04.tar.xz
cd amdgpu-pro-18.50-725072-ubuntu-18.04
./amdgpu-pro-install

Add amdgpu.dc=1 to GRUB_CMDLINE_LINUX in /etc/default/grub run sudo update-grub and reboot into kernel 4.15.0-47-generic.

And Voilà
Cheers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.