10

I am running Ubuntu 18.04.2 under VMWare Fusion on a macbook pro.

It just downloaded an update, and, after it rebooted, the display was no longer scaling and the scaling option had disappeared from the display settings.

I was able to set the scaling again using xrandr, but I have to set it every time after a restart...

I tried following the directions here, but it is not working:
https://www.valhalla.fr/2018/07/14/hidpi-on-gnome-desktop/

Does anyone know what happened to the scaling option in the GUI and how I can get it back?

Here's a screenshot of what I am now seeing Here's a screenshot of what I am now seeing

7
  • YES I thought I was going crazy! So this is an issue. I briefly believed I had completely imagined myself using the scale switch. Using Ubuntu in VMWare Workstation on a Surface Book, and can't find a solution for this anywhere. Did you?
    – Will
    May 25 '19 at 18:39
  • 1
    @Will Not really... VMWare Fusion has since had a few updates, and so has Ubuntu, and somewhere along the line the option appeared again. I don't know what did it, unfortunately. I also installed gnome-tweaks but I have no idea if that has anything to do with it.
    – togaen
    May 26 '19 at 19:24
  • @togaen Did you resolve the scaling problem? I have the same issue but I don't find something working. Jun 13 '19 at 19:28
  • @amorvincomni As I said above, it just randomly started working again... I don't know what happened to fix it.
    – togaen
    Jun 14 '19 at 20:03
  • 1
    just found the solution: go to Edit > Preferences > and make sure Display "Autofit Guest" is checked
    – luffy
    Jun 27 '19 at 9:41
1

You can try this command

gsettings set org.gnome.desktop.interface scaling-factor 2

Then restart your system.

I am also on mac but I am using Parallel Desktop. There is a scaling and more space option available in parallels graphics settings. After this command whenever I change to scale and then back to more space, I get 200% scaled desktop.

Although also in this you will have to do it every time you open ubuntu but no restarting is required.

You can also try this in VMWare Fusion

0

I have a similar problem with VirtualBox. The scaling option doesn't appear in the Display settings.

I tried Vishal's solution:

gsettings set org.gnome.desktop.interface scaling-factor 2

but it had no effects (either immediate or after a reboot).

I'm thinking that since this is a VM with a "made up" video board, the option is just not available.

What I can do, though, is to turn on the "Scale to Window" feature of VirtualBox. Then I can resize the window. In effect, it's the same thing. Use a lower resolution of Display and then make the window about 4× bigger (2× in width and 2× in height).

0

When we talk about VM, the idea is a bit complicated: There is your machine specifications and your VMWare settings which could be affecting it. After the update, Ubuntu simply detects any possible scale factors, and when it detects none, it doesn't show the scaling menu. There is one exception, though, for enabling fractional scaling. If performance is not much of a problem to you (mostly because you are using a MacBook), you can use the command gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']", restart the machine, and return to display settings. You should see some options at this point.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.