1

I recently purchased Lenovo Thinkpad E585 with AMD Radeon Vega 10 graphics card and preinstalled Windows 10. To install Ubuntu 18.04.2 in dual boot, I have shrunk my C drive. Now, when I boot with a flash drive and Grub screen appears, my screen turns black upon pressing 'Install Ubuntu'.

Following this famous question: 'My computer boots to a black screen, what options do I have to fix it?' and one here, I replaced quiet splash with nomodeset and then with acpi = off and radeon.modeset=0 but nothing of them worked. Replacing with nolapic brought some lines of text but it stopped there and didn't proceed further in about half an hour so I had to forcefully turn the laptop off.

Flash drive has no issue as the same bootable flash drive is working on my old laptop. Also, my Ubuntu image file is okay as I tried several images and all of them bring this issue. It appears this also has nothing to do with UEFI vs Legacy modes: I initially had fast startup and secure boot enabled and this issue appeared. Then I disabled both of them and played with UEFI and Legacy settings in BIOS but it didn't help. Hence, I believe the issue lies with the AMD graphics card.

  • What tool did you use to create the bootable USB? Can you try using a different tool? I have sometimes found this sort of problem goes away when using a different tool to make the installation USB. – terdon Mar 7 '19 at 10:14
  • First I used, rufus and then I tired Universal USB Installer. The issue was there with both these attempts. Actually, my bootable flash drive works with my old laptop so I guess bootable USB creating tool is not causing any issue. – Awais Mirza Mar 7 '19 at 10:22
  • The ThinkWiki page is a wonderful resource for thinkpad owners. Unfortunately, I didn't find a page for your model, but maybe you can find information for a model with a similar setup: thinkwiki.org/wiki/Installation – terdon Mar 7 '19 at 10:37
  • @terdon, I searched ThinkWiki but couldn't find the solution. This morning I came across another solution and this one worked so I have just posted it below. – Awais Mirza Mar 9 '19 at 13:23
1

Initially, you will have to edit 'Install Ubuntu' for installing Ubuntu and then after the installation, you will edit grub (this will make changes permanent) as follows:

For Installation

  1. Highlight 'Install Ubuntu' and press e.

  2. Add the following text after quite splash and before ---:

    ivrs_ioapic[32]=00:14.0 spec_store_bypass_disable=prctl

  3. Delete ---

  4. Press F12 to boot.

After Installation

To make the changes permanent, do the following. (Else you will have to perform the above steps each time you log in.)

  1. In the Terminal, enter sudo nano /etc/default/grub

  2. Append "quiet splash" to look like

    "quiet splash ivrs_ioapic[32]=00:14.0 spec_store_bypass_disable=prctl"

  3. Press ctrl+x to exit and Y to save the edits.

  4. Execute sudo update-grub in the terminal.

When you restart next time, you shouldn't get the blank screens anymore.

Sources: https://www.reddit.com/r/Ubuntu/comments/9tdut2/im_trying_to_install_ubuntu_1804_on_my_lenovo/
https://medium.com/@jthegedus/ubuntu-18-04-lts-on-lenovo-thinkpad-e485-15e1d601473f

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.