1

I have Ubuntu MATE 16.04.6 LTS installed on a system with two monitors.
They act normally when I login to default MATE 1.12.1 session.

But the LightDM login screen looks weird on both screens:

  1. 1600x900 normal landscape (no rotation)

    1600x900 landscape

  2. 1280x1024 left portrait rotation

    1280x1024

Details about lightdm:

$ dpkg -l | grep -i lightdm
ii  liblightdm-gobject-1-0:amd64   1.18.3-0ubuntu1.1  amd64  LightDM GObject client library
ii  lightdm                        1.18.3-0ubuntu1.1  amd64  Display Manager
ii  lightdm-gtk-greeter            2.0.1-2ubuntu4     amd64  simple display manager (GTK+ greeter)
ii  lightdm-gtk-greeter-settings   1.2.1-0ubuntu1     all    settings editor for the LightDM GTK+ Greeter
ii  ubuntu-mate-lightdm-theme      16.04.7            all    LightDM theme and default configuration for Ubuntu MATE

$ cat .dmrc 
[Desktop]
Session=mate

Details from /etc/default/grub.cfg:

$ cat /etc/default/grub | grep LINUX_DEFAULT
GRUB_CMDLINE_LINUX_DEFAULT="verbose INIT_VERBOSE=y noplymouth"

I see this on every boot-up and currently I enter my password blindly.

How and where should I fix this problem?

Update 1: passing nomodeset in GRUB fixes LightDM login, but disables screen rotation of right monitor.

Update 2: temporary fixed by installing kylin-greeter ("The greeter for the Kylin desktop fork from unity-greeter."), but still need solution for original problem with LightDM and unity-greeter.

1

For screen rotation restoration; Try this...

For the initial text console?

Check: http://askubuntu.com/questions/237963/how-do-i-rotate-my-display-when-not-using-an-x-server

... and/or check the content of /etc/default/grub and make sure it contains something similar to

GRUB_CMDLINE_LINUX_DEFAULT="noplymouth video=efifb fbcon=rotate:3"

then do

$ sudo update-grub

This should make all after the grub menus/screens be rotated accordingly.



For X?
Arrange your screens with the "System Settings" > "Displays"
Then make sure that /var/lib/lightdm/.config/monitors.xml is lightdm-owned copy of $HOME/.config/monitors.xml. Take into use: reboot to see the effect.

  • Both solutions does not work. GRUB one rotates both screens, LightDM config is not applied even if I copy it manually with sudo cp $HOME/.config/monitors.xml /var/lib/lightdm/.config/monitors.xml; sudo chown -R lightdm: /var/lib/lightdm. – N0rbert Mar 12 at 17:35
  • You should have instances saying other than "normal" in the output from grep on both files, as in: sudo grep rotation /var/lib/lightdm/.config/monitors.xml .config/monitors.xml - if you do have it, then I have no more clues. – Hannu Mar 17 at 20:04
  • BTW, do: sudo chown -R lightdm:lightdm /var/lib/lightdm to ensure the group is set too ! – Hannu Mar 17 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.