1

I have been repeatedly getting an error upon logging into Ubuntu MATE saying that my "indicator applet complete" has quit unexpectedly. I can choose to reload it which fixes it, but when I reboot the computer or log out and log back in, the error comes back. I have found that running killall mate-panel once the error comes up will work to fix it. I tried making the computer run killall mate-panel every time I log in, but it doesn't always work correctly and when it does work, the error will show up for a second or two before the command runs and resets the panel, getting rid of the error. By the way, I am running Ubuntu MATE 18.04. If anybody knows a solution, please share.

UPDATE: my MATE Tweak window has these options available to me: MATE Tweak panel settings

  • If anybody has any ideas whatsoever, please share. I really need to find a solution to this problem – GNULinuxOnboard Mar 7 '19 at 18:04
  • Try to run MATE Tweak with mate-tweak, then toggle all indicators from Panel (Interface) -> Enable indicators. – N0rbert Mar 7 '19 at 19:25
  • What do you mean? I'm in MATE tweak, but what do you mean by toggling all indicators? – GNULinuxOnboard Mar 7 '19 at 20:31
  • I mean this checkbox (ran on 16.04 LTS, but 18.04 should have similar). Try to uncheck it and then check again. – N0rbert Mar 7 '19 at 20:34
  • 1
    I tried re-installing the "indicator applet complete" package, which did not fix anything. I might try re-installing the whole mate panel? I don't know if that would be very effective, and I'm concerned it might mess up some other stuff. Anyway, I'll ask around on the ubuntu-mate community and see if I can get any answers. – GNULinuxOnboard Mar 7 '19 at 20:54
3

I was looking at a file called .x11errors in my home directory and found that indicator-applications couldn't load.
This is because

.local/share/gvfs-metadata/home

was set to root privilege and should be user privilege. After that, my indicator-applet-complete errors no longer showed.

| improve this answer | |
  • Thank you. I assume this would work, so I marked it as correct, but I have since re-installed Ubuntu MATE and the problem no longer persists. Thank you very much! – GNULinuxOnboard Sep 16 '19 at 14:18
  • doesn't work for me. I tried even: chwon nobody:nogroup with 0666. – dawciobiel Mar 19 at 18:39
0

This workaround works. Put the script in your Startup Programs. @dawciobiel

#!/bin/bash
# 
#----------------------------------------------------------------------------
#
# Simulate Return key
#----------------------------------------------------------------------------
sleep 5

xte 'key Return'
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.