0

I am on alienware R-3. I did the following steps multiple times with different partitions without any luck.

  1. In bios changed RAID-0 to ACHI
  2. In bios changed secure mode to disable
  3. Logged into windows and shrink the disk
  4. Made a bootable ubuntu usb with rufus
  5. Boot from ubuntu usb and installed ubuntu

Now in bios if I keep the setting on Legacy I can directly login to Ubuntu. If I keep it to UEFI I directly log in to UBUNT.

I tried to manually enter into grub but legacy dont see UEFI and vice versa.

Ideally I want to present a menu to select one in UEFI mode. If not possible I wouldn't mind getting both in legacy mode.

Please help. Thanks.

  • How the USB boots is how it installs, so you need to figure out how to boot it in UEFI mode. Ubuntu works with secure boot (unless the vendor messes with the standard), so try with secure boot enabled. Easier than changing Windows to legacy. – ubfan1 Mar 6 at 16:34
  • I changed options from legacy to UEFI and enabled secured mode but now it goes straight to windows – Mian Asbat Ahmad Mar 6 at 16:42
  • The boot-repair app detects both windows and ubuntu in advanced -> grub location but when I try to fix it, boot-repair says that your session is not UEFI. The problem is that if I changed from ACHI to UEFI then I cant login to Ubuntu. – Mian Asbat Ahmad Mar 6 at 16:52
0

When windows boots to UEFI it typically boots to windows boot manager rather than booting straight to the OS.

The simplest solution would be to either have both partitions imaged with legacy images, or have the legacy image on one hard drive and your uefi image on another.

  • I would have done that but my colleague having the same model has both windows 10 and ubuntu in one hard drive on the same model in UEFI settings. – Mian Asbat Ahmad Mar 6 at 18:54
0

Okay I was able to solve it finally. Here are reasons and directions of how to solve it.

REASON:
The above situation is due to preinstalled Windows 10 in UEFI mode and Ubuntu installed in LEGACY Mode.

SOLUTION TO WHOLE PROCESS:
1.0: Press F2 on boot and change RAID ON to ACHI and in boot menu disable secure mode.

  1. Make a UEFI only USB by formatting usb as FAT32 and copy paste the contents from Ubuntu.iso to that usb.
  2. Now press F2 to go to setup and manually add an entry to grub.efi
  3. Keep the manual entry on top so that the computer boots from this option
  4. Reboot the computer and you will be on the grub screen.
  5. Now on install option press e to edit and add the option for nomodeset or the desktop will freeze in Alienware because of NVIDIA graphics card.
  6. Now press enter and the installation will start.
  7. When you go to disk partition, select something else option
  8. Now select the unallocated space and make swap partition double the amount of ram.
  9. Now assign the remaining partition to /
  10. At the bottom on the same screen install the boot loader into the same / partition.
  11. Reboot and after installation select try ubuntu and perform step 5.
  12. When you get the desktop.
  13. Open terminal and install boot-repair
  14. sudo add-apt-repository ppa:yannubuntu/boot-repair sudo apt-get update sudo apt-get install -y boot-repair && boot-repair
  15. Folow the steps and you will get both windows and ubuntu options in the grub.

Note: If you get the boot-repair is not in UEFI Mode screen in boot-repair app then it means you havent done step 2 properly. Thats the reason we made UEFI only usb to make sure that we are not in ACHI mode but in UEFI mode.

I have written the above steps from memory so let me know if any problem and I will try to help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.