4

I have been using a Dell xps 15 9560 laptop with Ubuntu 16.04 since the 9560 was released. In December of 2018, I received two Dell U2717D monitors and have been connecting them to my laptop so that I could have three displays (my laptop's screen plus the two monitors). I have been using a USB-C to Displayport connection for one monitor and just straight HDMI for the other. This has been working well for me up until this morning (nearly three months after receiving the monitors).

This morning, as usual, I opened my laptop, plugged in both monitors, and switched them on. Everything was seemingly normal except my computer's background was not appearing on any of my displays, though I could go on the internet and open all other applications just fine (though things were a bit glitchy). I attributed this to standard Linux-related headaches, so I decided to restart my computer. Now here is where things get interesting. My computer booted up as normal and everything was displaying on all three monitors during bootup but, once I logged in, both external monitors said that they were not receiving signal from my laptop. I decided I should unplug both and plug them back in, as you do, to see if that would change anything. Once I unplugged the HDMI cable, my second monitor popped up its normal display. I plugged the HDMI cable back in, both monitors displayed the same "no ____ signal from your device" again. I then unplugged the USB-C connection and the HDMI-connected monitor popped its normal display back up. I plugged the USB-C cable back in and, yet again, I was met with "no ____ signal from your device" on both monitors yet again.

At this point I was mildly frustrated and I looked in the display settings and it showed only one external monitor plugged in (keep in mind they are both plugged in at this time) and it was set to "off" so I toggled it to "on" and nothing happened. Using xrandr, it shows that both monitors are connected. Now here is where things get even stranger. I decided to just restart my computer once more and, during the restart process, both monitors immediately displayed their normal contents. Even on boot, both external monitors were displaying their normal contents. I finally made it to the login screen, typed in my password and pressed enter (feeling accomplished at this point for doing nothing). Immediately upon signing in, both external monitors immediately gave me their "no ____ signal from your device" messages once again. Now I am here and wondering if anyone knows what could possibly be the cause of this. I did quite a bit of searching online but it seems that no one has run into this specific problem.

A side note, I do not know if it matters, but I was able to connect my phone to my computer via USB-C with the HDMI monitor also connected and everything worked just fine. I am literally only running into problems when I am signed in.

TL;DR

Laptop: Dell xps 15 9560

OS: Ubuntu 16.04

Problem: Have two external monitors (both Dell U2717D), one connected via HDMI and the other connected via USB-C to Displayport. Setup worked for three months, then, randomly, stopped working this morning when both are plugged in. Both work fine during shutdown and boot sequence but, once I login, I can only get one to work at a time.

Thank you in advance for any insights/assistance.

Edit: For what it is worth, I am using kernel 4.8.0-41-generic

  • Have you tried logging in through another user? (creating a new one if necessary) It might show if it's a user config issue or a global issue. Also, had you run any updates or installed any new software or changed any configurations recently? – anonymous2 Mar 5 '19 at 16:04
  • I just tried that (through both the guest account and a new test user account) and both monitors seem to be working together just fine! So that narrows it down to a user config issue. The only thing I have recently done is a fresh install of lua, luarocks, and torch. I always accept the standard Ubuntu updates but this is the first time I have reset my computer in about a month. I do not know that these updates have had any impact though, since I seem to be able to use both monitors just fine on the other accounts. But I have not changed any configurations at all. – MPT Florida Mar 5 '19 at 16:30
  • It's just an idea, but you could try removing (or just renaming) the .Xauthority file in your home directory and restarting. Sometimes permissions of that file get messed up and simply removing / renaming it forces the xsession to generate a new, clean one. Also, do you have any backups of your home folder? Would it be possible to restore specific suspect config files to a previous date? – anonymous2 Mar 5 '19 at 17:38
  • Thank you for the suggestion! I just tried renaming the .Xauthority file and restarting my computer and, sadly, it had no effect. Unfortunately, I think the only backup of my home folder is from quite some time ago (I am definitely taking this as a lesson learned in the context of always keeping current backups). – MPT Florida Mar 5 '19 at 19:59
  • Yeah, can always be helpful... :) Okay, what happens if you try finding recently modified files in your .config folder (ie., with find -cmin -1000 or however many minutes you think it has been since it stopped working). Do you find anything that looks particularly suspicious? Anything which looks graphics related? My thought is that given that it's just one user, with enough work you should be able to pinpoint what file is messed up and simply restore it from a backup user. – anonymous2 Mar 5 '19 at 20:19
2

Working together, we (the OP and I) discovered that the issue lay in user configs, since both guest user and new test user accounts worked normally, but the original account still failed to work. Removing the .Xauthority file did not fix the issue.

Finally, it was suggested that the OP try to find files in the .config user folder which had been modified recently using something along the lines of:

find -cmin -1000

...using the number of minutes the OP suspected the file had been corrupted for instead of 1000. Doing so showed few suspicious files except a file called monitors.xml. Opening the file, there was nothing which aroused particular suspicion, but on the chance, the OP renamed the file and restarted the computer.

The problem is totally resolved.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.