0

I have a new Lenovo laptop with an AMD Radeon RX 500 graphical card. There is also an integrated Intel graphical card. I just installed the latest Ubuntu 18.04.2 LTS one week ago. I would like to install OpenCL sdk. I downloaded the official drivers https://www.amd.com/en/support/graphics/radeon-500-series/radeon-rx-500-series/radeon-rx-550, installed them as instructed, but after rebooting could not login into Ubuntu. I read all across the internet and this issues is common, but nothing seemed to work for me.

When I tried amdgpu-pro-install --px I got Unable to locate package xserver-xorg-video-modesetting-amdgpu-pro. I later read that this option was deprecated. I also tryed the -headless installation and got the same result.

When I run amdgpu-pro-install I get WARNING: amdgpu dkms failed for running kernel. My kernel is 4.18.0-15-generic.

Hope someone can help.

  • 1
    Did you disable Secure Boot? – Pilot6 Mar 5 at 14:55
  • Yes, Secure Boot was disabled – JanaF Mar 8 at 10:45
  • 2
    Maybe the driver is incompatible with the 4.18 kernel. – Pilot6 Mar 8 at 10:48
0

You will be able to login after uninstalling amdgpu:

  1. Press Ctrl+Alt+F2 in login screen.
  2. Login with your credentials.
  3. Run amdgpu-uninstall
  4. Run reboot
  • I know how to uninstall it, but this still does not solve my problem. How can I install the amdgpu-pro drivers on Ubuntu with two graphical cards? I would really like to use OpenCL which is impossible without the drivers. – JanaF Jul 9 at 11:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.