0

enter image description hereTrying to set desktop background to a jpg file, but when I select the folder (left click on a spot where there is no icon on the desktop > select "Desktop settings" > lower left area there is "Folder:" > and next to it drop down list > click on "Other" > opens up "Select folder" file-browser window) files are grayed out. When I click "Open" it goes back to Desktop settings window and nothing is showing in Background tab. I searched the internet, and none of the answers seem to work. I have not tried yet the command line method. This is xubuntu, 18.04, xfce.

migrated from meta.askubuntu.com Mar 5 at 8:58

This question came from our discussion, support, and feature requests site for Ubuntu users and developers.

  • 1
    Please edit your question and give us more details. What folder? How are you "selecting it"? In what tool? What's in the folder? What are the permissions of the folder? – terdon Mar 5 at 8:59
  • @terdon - edit done. Important additional information: I solved the problem by going into Thunar, navigating to the folder where my intended jpg file is, then left click on the file offered choice to set the image as wallpaper. In fact this is dangerous because it happened to me once that a left click on an image and an inadvertent mouse pointer motion resulted in replacing my desktop background (a.k.a. "wallpaper"). A confirmation window would be advisable. At that time I spent hours trying to restore my desktop image not knowing how it happened. Anyway, the original question stands. – Janos Mar 5 at 14:08
  • What Ubuntu are you using? What desktop environment? Gnome? Unity? Something else? Why are you trying to set a folder as the background? What files are greyed out? Are they image files? Can you at least show us a screenshot? – terdon Mar 5 at 14:16
  • @terdon - sorry, I don't know if it is Unity or Gnome - whatever came with the 18.04 and all of its updates. I'm not trying to set a folder as background, it is what Desktop settings asks from me. Yes, they are jpg files. How do I attach a screenshot? I already have it. – Janos Mar 5 at 17:56
  • Oh, sorry, you had already said you were using xfce, I missed that. See askubuntu.com/help/formatting (at the end) for how to include images. We would also need to see the output of ls -l /foo where /foo is the folder you are trying to use. I want to see that you are indeed trying to use an image file (you never know) and that you have permissions to access that folder. – terdon Mar 5 at 18:00

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.