I was hoping someone could possibly help me out with my sound card. I have a Soundblaster G6 running in 18.10. Everything seems to work except the microphone input. I realize Creative Labs doesn't officially support Linux, but since everything else is working. I was wondering if perhaps there was something I could do so that I could use my headset microphone while using it.

Can anyone point me in the right direction?

2 Answers 2


I found a simple solution. Tested on Ubuntu 20.04.1 (and Fedora 31).

1. Open alsamixer


2. Choose your soundcard


Sound BlasterX G6
Hit Enter to select the card

3. Activate 'Capture' for 'Line In' and 'External Mic'

Use left-right arrows to navigate to the 'Line In'.
Use Space to activate the 'Capture'
Use left-right arrows to navigate to 'External Mic'
Use Space to activate the 'Capture'

4. Configure PCM Capture Source

Use left-right arrows to navigate to 'PCM Capture Source'
Use up-down arrows to select 'External Mic'
Press ESC to save

5. Record a WAV to test the microphone

arecord -f dat -d 2 /tmp/test-mic.wav -vvv

6. Playback the WAV

aplay /tmp/test-mic.wav

7. Make the change persistent (fail)

After a reboot, The 'PCM Capture Source' keept going back to 'Line In'. I tried a systemd unit file (After=sound.target dbus.service) or a startup script in .zprofile... nothing worked. I think this is because the card takes some time to startup. So I came up with this workaround :

vim ~/bin/setmic

And add this:

#!/usr/bin/env bash

cardNumber=$(aplay -l|grep 'Sound BlasterX G6'|cut -d' ' -f 2 |tr -d ':')
amixer -c "$cardNumber" -q set "PCM Capture Source" "External Mic"

if [ $? -eq 0 ]; then
  echo "PCM Capture Source successfully changed to 'External Mic'"
  echo "Failed to configure PCM Capture source for Sound BlasterX G6"

amixer -c "$cardNumber" -q sset 'Input Gain Control' 3

if [ $? -eq 0 ]; then
  echo "Input Gain Control set to 3"
  echo "Failed to activate mic Boost for Sound BlasterX G6"

~/bin beeing in my PATH:

chmod u+x ~/bin/setmic    

> PCM Capture Source successfully changed to 'External Mic'
> Input Gain Control set to 3
  • 2
    @Nmath Although input to confirm that this works, either by the OP or by anyone else, would be valuable, please note that What topics can I ask about here?, which is the page you linked to, is about what topics people can ask about here, and it does not say anything about answers. Jul 8, 2020 at 2:01
  • Sorry for the Fedora thing. Tested on Ubuntu 20.04.1, it works!
    – Honiix
    Aug 7, 2020 at 20:13
  • Edited 'setmic' to also increase the Microphone Boost to +30dB
    – Honiix
    Oct 13, 2020 at 7:57
  • So how do you run setmic? Manually on each startup? Maybe you can add somesleep and add it to startup scripts?
    – AlexP11223
    Nov 19, 2020 at 15:04
  • Manually each time I need the Mic. It was almost impossible to know when the mic is ready. It could be minutes after the boot.
    – Honiix
    Nov 24, 2020 at 7:59

I figured it out. Need to add an entry to pulseaudio to get it to see the input from alsa. I posted a tutorial on the process on reddit here

  • I did also get Skype working. It seems Skype was by default changing the capture device in ALSA to line in. So I had to go back in there, change it to "External Mic" and then reselect it in both pavucontrol and pulseaudio. Somehow, running Skype for Web in Chrome let meu se it with "default device" selected. Once I did that, the skype desktop app could be used with default device without any issues.
    – Cerebrix
    Mar 20, 2019 at 14:52
  • 4
    Could you expand this to include the steps here, in case the link changes in the future?
    – Zanna
    Jul 8, 2020 at 1:52
  • 1
    can you please tell me what entry you added to pulseaudio? The link isn't there anymore...
    – Elfie
    Mar 24, 2021 at 10:00
  • What @Elfie said. I'd like to know, too.
    – telometto
    May 6, 2022 at 23:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .