0

I have a tp-link ac1900 archer T9UH wifi adapter that I’m trying to use on my 16.04 lts machine. The box for the tp-link states: Linux (kernel 2.6.18-4.4.6) However this means that you need to find a zipfile on the tp-link website wich contains code and instructions on how to “make” the driver and install it. And that’s where things went wrong. The instructions are straightforward:

$ make clean
$ make
$ sudo cp 8814au.ko /lib/modules/4.4.0-142-generic/kernel/drivers/net/wireless/
$ sudo depmod –a

output: modprobe: FATAL: Module 8814au.ko not found in directory /lib/modules/4.4.0-142-generic

I have then tried 3 different variants on this theme that I found on this site all with similar results. Last one I tried is this one: I'm Trying to install rtl8814au drivers fairly new to linux specifically these commands:

$ sudo apt-get update
$ sudo apt-get install git dkms
$ git clone https://github.com/sbosshardt/rtl8814AU.git
$ cd rtl8814AU
$ sudo ./dkms-install.sh

Alas no working wifi adapter but I now have this output from running the script:

sph@SKYBOL:~/Desktop/driver3/rtl8814AU$ sudo ./dkms-install.sh

About to run dkms install steps...
Creating symlink /var/lib/dkms/rtl8814AU/4.3.21/source -> /usr/src/rtl8814AU-4.3.21
DKMS: add completed.
Kernel preparation unnecessary for this kernel. Skipping...
Building module:
cleaning build area....
'make'......................
Signing module:
- /var/lib/dkms/rtl8814AU/4.3.21/4.4.0-142- generic/x86_64/module/8814au.ko
Secure Boot not enabled on this system.
cleaning build area....
DKMS: build completed.
8814au:
Running module version sanity check.
Error! Module version v4.3.21_17997.20160531 for 8814au.ko is not newer than what is already found in kernel 4.4.0-142-generic (v4.3.21_xxxx.20171031_beta).
You may override by specifying --force.
depmod....
DKMS: install completed.
Finished running dkms install steps.
sph@SKYBOL:~/Desktop/driver3/rtl8814AU$

And when I do: sph@SKYBOL:~$ dkms status
rtl8814AU, 4.3.21, 4.4.0-142-generic, x86_64: installed (WARNING! Diff between built and installed module!) virtualbox, 5.1.38, 4.4.0-142-generic, x86_64: installed

This looks like this problem: Install rtl8814AU driver on ubuntu 16.04

However I am not sure how to proceed.
Do I use –force like the error message suggests?
If so where do I use it?
Also I am not sure how “unclean” my system has become.
Are there any files left laying around from previous attempts that will interfere with new attempts at installing the right driver?

Output of lsusb command:

Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 006: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 002 Device 005: ID 8087:07dc Intel Corp.
Bus 002 Device 003: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 002 Device 002: ID 2357:0106
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

the device with ID 2357:0106 is the wifi adapter according to wikidevi ( https://wikidevi.com/wiki/TP-LINK_Archer_T9UH )

  • Can you format the text to get it readable? askubuntu.com/help/formatting – Pilot6 Mar 4 at 20:07
  • Your problem is that you are trying to install the driver both ways instead of choosing one. – Pilot6 Mar 4 at 20:09
  • And also you installed a wrong driver first. 88x2.bu and rtl8814au are different drivers. – Pilot6 Mar 4 at 20:11
  • @Pilot6 : How do I choose the right one? As for the 88x2.bu driver: that is just in the example text from the tp-link zipfile. I did subsistute the rtl8814au driver. Also: do I need to revert/cleanup anything? – huls Mar 5 at 7:31
  • I have removed the version that I had installed using DKMS. At least I think I did. $dkms status does no longer show this module. @Pilot6 Question now is how to proceed. – huls Mar 10 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.