1

I ran vpn(PPTP and openvpn both doesn't make any different) on my ubuntu (In my country some sites like telegram ,youtube or twitter are block and I have to run vpn to access them) So after I ran vpn , telegram messenger worked well but the browsers didn't work and all block site like youtube still couldn't be accessed (but the normal sites could be accessed.In the other hand,vpn didn't any effects on block sites when I use browsers) I also did ping block sites but it didn't work out The funny thing is sometimes when I power on my lap top and after connect to AP immediately start vpn (at the very first seconds) , all browser work and I can access to any block site

here's my ip route output command

default dev ppp0 proto static scope link metric 50 
default via 192.168.1.1 dev wlp2s0 proto dhcp metric 600 
10.10.0.0 dev ppp0 proto kernel scope link src 10.10.11.239 metric 50 
169.254.0.0/16 dev ppp0 scope link metric 1000 
172.16.77.0/24 dev vmnet1 proto kernel scope link src 172.16.77.1 
172.16.149.0/24 dev vmnet8 proto kernel scope link src 172.16.149.1 
185.180.15.243 via 192.168.1.1 dev wlp2s0 src 192.168.1.120 
185.180.15.243 via 192.168.1.1 dev wlp2s0 proto static metric 600 
192.168.1.0/24 dev wlp2s0 proto kernel scope link src 192.168.1.120 
metric 600 
192.168.1.1 dev wlp2s0 proto static scope link metric 600 

ppp0 is my vpn and wlp2s0 is my wireless card

5
  • Hi, you will need to clarify what it is exactly you are asking, before anyone can help you. Some sites will block certain VPNs. As you can access and use the Internet normally over the VPN, and only some sites have issues, it seems like this is not an issue with Ubuntu, but either with your VPN provider or sites blocking them specifically, for sites you cannot access.
    – dobey
    Mar 3, 2019 at 23:03
  • Hello, let me put it this way, when I run the vpn in windows 10 , all sites are accessible and I don't have any problem(I use dual boots), but when I run the VPN on Ubuntu, I can access to some application like Telegram that's block in my country but on my browser most the time I cant't access to any site that is block , in the other word most the time the traffic of my browsers don't go through my VPN @dobey
    – Afshin
    Mar 4, 2019 at 6:19
  • There is nothing special about the browsers unless you've configured them to use some proxy, such that their traffic will try to go through that proxy. Beyond that, Firefox/Chromium use the same network routing as everything else in the system.
    – dobey
    Mar 4, 2019 at 13:28
  • Also, "can't access" is very vague. Please edit your question to clarify what exactly you're asking, and to provide specific details of what you mean by "can't access" (DNS error, re-direction to a warning site, etc…).
    – dobey
    Mar 4, 2019 at 13:31
  • Some websites are blocked by government like youtube or telegram so I need to use VPN to access these websites , In windows when I turn on my VPN I can access to all of them but in ubuntu I can't ping for example youtube website (can't ping also the ip address of youtube) but some websites which aren't blocked , are accessible and I can ping them ( when VPN in on) , so I can say I turn on vpn but not all of applications go through it , I hope I could be able to say clear my problem @dobey
    – Afshin
    Mar 6, 2019 at 14:04

1 Answer 1

6

I solved the the problem ! The problem was DNS ,so you should first install resolvconf , but why?? when you use this feature your system first read the dns server from this and then write it to /etc/resolv.conf so for installing this you should simply run this command :

sudo apt-get install resolvconf

And after doing that you should edit head file in the /etc/resolvconf/resolv.conf.d/head and put the DNS servers like in it :

nameserver 1.1.1.1
nameserver 8.8.8.8
nameserver 1.0.0.1
nameserver 2606:4700:4700::1111
nameserver 2606:4700:4700::1001

And for more sure you can go to your vpn connection and put the DNS in that too.

3
  • Its working for me, thanks. Jan 19 at 14:10
  • sure my friend, but the main problem was the MTU size of the packets, I don't know why but apparently when I was connected to any VPN, I had to change my MTU size for that interface from 1500 to 1380(I don't know the exact number, it was a long time ago. If it doesn't work, try decreasing it by 10
    – Afshin
    Jan 20 at 6:11
  • ,Do you know why my internet is stopped working while I connect with NordLayer VPN? I am not able to search through the browser when I connect with NordVPN. Jan 20 at 8:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.