0

I have attached a new keyboard in UK layout to a 18.10 computer. Previous keyboard layout was German.

I can add the new keyboard layout in Settings -> Region & Language -> Input Sources. Clicking on the [+] plus button lets me choose English (United Kingdom) -> English (UK) -> Add. Now I can activate the keyboard layout in the layout chooser clicking on "en", and it works:

  • Shift + 2 produces @
  • Shift + 3 produces #

This matches the symbols on the physical keyboard. But the next time I log in, although "en" is still selected,

  • Shift + 2 produces "
  • Shift + 3 produces £

I understand that this is the English (US) layout instead of (UK). Switching temporarily to "de" layout and back to "en" does not help.

The only thing that I have found helps is to open Settings again, delete the English (UK) entry, add it again, then select "en" again from the keyboard layout chooser.

How can I prevent this from happening?

This is ubuntu 18.10 with the default desktop. Initial installation on this computer was with Ubuntu 17.10, and it has since seen upgrades to 18.04 and then to 18.10.

0

What finally worked was to select the Keyboard layout Endlish (United Kingdom) with the subtype English (Australian). In the keyboard layout chooser, this is now displayed as just English (Australian).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.