1

I have followed this tutorial without success.

I have kernel 4.18.0-15-generic, xubuntu 18.04.2.

I have bluez version 5.48-0ubuntu3.1 which is more than new enough according to the tutorial.

I am able to interact with bluetooth devices, including low power bluetooth devices, using other applications. But navigator.bluetooth remains undefined.

I am:

  • Running bluetoothd with the -E option.
  • Running google-chrome with the --enable-web-bluetooth option.
  • Running chrome 72.

Still no navigator.bluetooth in JavaScript land.utI am running on a Dell Chromebook 13 - 7310, that's Broadwell hardware, with the mrchromebox firmware to boot xubuntu normally. But as I noted, non-Chrome apps see bluetooth just fine.

Thoughts?

Thanks!

  • What exact error do you get? I see: Web Bluetooth API is not available. Please make sure the "Experimental Web Platform features" flag is enabled. even when the bluetoothd -E is used, so looking at the man page for bluetoothd: -E Enable experimental interfaces. Those interfaces are not guaranteed to be compatible or present in future releases. (on an 18.04 system, 4.15 kernel... still far later releases than the tutorial. What device are you trying to see? Some "bluetooth" gpses like the Delorm earthmate bluelogger need all sorts of rfcomm setup,... to feed into the gpsd. – ubfan1 Mar 4 at 2:13
  • navigator.bluetooth is undefined. That's not an error message, it's a property of the navigator object that should be present if bluetooth support is present in Chrome. I have seen the messages you mention. However bluetooth works perfectly everywhere except chrome. – Tom Boutell Mar 5 at 16:08
  • My device is a smartibot, but the issue is that navigator.bluetooth does not exist in javascript land at all, I don't get as far as inquiring about devices from there. – Tom Boutell Mar 5 at 16:09
1

Following the tutorial, when you launch Chrome, you still have to enable the chrome://flags/#enable-experimental-web-platform-features flag before the URL https://googlechrome.github.io/samples/web-bluetooth/discover-services-and-characteristics.html will work. This worked on my plain vanilla Chrome setup on Ubuntu 18.04.

  • Thank you, I couldn't find this switch and assumed it was no longer needed. That link gets me there on my mac here at work, I'll try it on my Ubuntu box later and report success. – Tom Boutell Mar 6 at 16:04

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.