0

I use WiFi for connecting to internet using my Ubuntu 18.04.2. It works fine. But, after some random interval of time, the internet connectivity goes down. The WiFi is still on and the device is connected to it(I also verified this by checking the active client list of my router by logging into the router from another device). After the connectivity goes down, I can't even ping my gateway(Router's IP). If I try to ping my router(IP 192.168.0.1), it shows that destination host is unreachable.

So, for troubleshooting the issue, I decided to take a look at my ARP table. After running the arp command, I see the following output:

Address                  HWtype  HWaddress           Flags Mask            Iface
192.168.0.1                      (incomplete)                              wlp13s0

192.168.0.1 is my router's IP address. This is it! the ARP requests are incomplete. This is the problem. But, I want to know exactly why this is happening. I know ARP poisoning is not being performed because, even if I disconnect all other devices and then perform an ARP request after clearing ARP cache, the problem still persists.

Surprisingly, if I turn off the WiFi and then turn it on again, I get my internet access back. This is a "temporary" fix of the issue. After getting my internet access back, if I run ARP request, I get the following response:

Address                  HWtype  HWaddress           Flags Mask            Iface
192.168.0.1              ether   My Router's MAC Addr   C                     wlp13s0

Can someone help me resolving this issue and tell me what next steps should I perform to fix this permanently?

Extra info:

My device uses RTL8723BE for WiFi connectivity and it has a known issue for having poor WiFi reception in Ubuntu. So, I use the rtlwifi_new driver by Larry Finger as suggested in this answer: https://askubuntu.com/a/722904/925252

11
  • 1
    Try to remove the out-of tree driver. Support of this adapter is OK in new kernels. The answer you referred to is 2 year old.
    – Pilot6
    Mar 3, 2019 at 9:55
  • @Pilot6 If I remove the driver, my laptop receives an extremely poor WiFi signal. Link Quality=28/70 (from iwconfig command). Mar 3, 2019 at 10:00
  • Did you use ant_sel parameter to fix antennas?
    – Pilot6
    Mar 3, 2019 at 10:00
  • @Pilot6 Yes, I need to set ant_sel=2 but, this thing does not work without this driver. Mar 3, 2019 at 10:01
  • It should work. What does modinfo rtl8723be | grep parm show? What is your kernel version?
    – Pilot6
    Mar 3, 2019 at 10:06

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.