3

I have a machine with Windows 7 (which apparently isn't being detected) and I'm trying to get it to dual boot W7 and Ubuntu. My BIOS (not UEFI!) is Phoenix Technologies 2.07 and through checking C:\Windows\Panther\setupact.log , I can confirm that it is a BIOS. I also know that the installer (running from USB device) is indeed in legacy mode because there's no splash screen like this: this one.

And I'm under the 4 partition limit. So, what am I doing wrong? Or is it safe to ignore the warning?

Screenshots and command outputs Boot menu Installation type screen Partition list screen Warning: "No EFI system partition was found. This system will likely not be able to boot successfully, and the installation process may fail." Crash message: "The 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot."

  • 1
    Boot from LiveUSB, select "Try Ubuntu" and post output of sudo parted -l and ls /sys/firmware/efi terminal commands. – Pilot6 Mar 3 at 15:46
  • (I added the screenshots to the album) So, there's no black and white menu but the installer is somehow in UEFI mode. I wonder if my USB stick can only boot in UEFI mode? I created it using Rufus and I was under the impression that would make it compatible with both BIOS and UEFI but maybe that's not the case. I'll try with Universal USB installer and see if that works. – Abe Mar 3 at 16:39
  • Please don't add screenshots. You can copy text from terminal. – Pilot6 Mar 3 at 16:44
  • That's weird. You said you don't have UEFI, but booted in UEFI mode. What if you run gparted and create an ext4 partition manually? But I am afraid that won't help. – Pilot6 Mar 3 at 16:47
  • Anyway you can go ahead installing, boot can be fixed later if the system doesn't boot. – Pilot6 Mar 3 at 16:48
4

What my problem was:

The installer was running in UEFI mode (there were files in /sys/firmware/efi) even though my system doesn't support UEFI and Windows 7 is installed in BIOS mode. In my BIOS's boot menu, there was only one option: to boot from USB HDD. To create the bootable USB stick, I initially used Rufus but I also tried Universal USB Installer; I'm not sure if that made any difference.

What worked for me:

after an unsuccessful installation (not sure if this is relevant) that failed with "The 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot.", I closed the error message, rebooted into Windows, deleted the EFI folder in the USB drive, restarted, booted from the USB drive and got this screen.

(Before, I was taken straight to the installer screen.) This time, Windows 7 was correctly identified by the installer (although I didn't get the "Install Ubuntu alongside Windows" option that assists with the partitioning). The only option is to select "Something else" as the installation type to manually do the partition. Since the Ubuntu root partition would leave me right at the limit of 4 primary partitions for BIOS, I decided not to create home and swap partitions. (Look into extended partitions if you'd like to have those.) The installation proceeded smoothly after that. partition list

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.