0

I've looked everywhere and can't solve this problem. I'm really new to advanced computer stuff and linux. I don't know what to include so just ask and I'll include it. I'm running ubuntu 18.04 on a CB3-111 acer Chromebook. In settings the only audio option is HDMI and it doesn't work. Originally there was only dummy audio as an option but I followed a tutorial that brought up HDMI as an option. I couldn't find the tutorial again but it only fixed the HDMI. I want to use internal audio and headphones but neither work. This is the return from the terminal command:

$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller (rev 0e)

and:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 3: Generic Digital [Generic Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: chtmax98090 [chtmax98090], device 0: Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: chtmax98090 [chtmax98090], device 1: Deep-Buffer Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Thanks for the help

5
  • What tutorial did you follow? Did you use crouton to install? – mchid Mar 3 '19 at 2:51
  • I did not use crouton. I used a bootable usb drive with Ubuntu 18.04 and followed this tutorial for the bios: ifixit.com/Guide/… – Ben Campbell Mar 3 '19 at 16:44
  • 1
    Found the tutorial that replaced dummy output with HDMI: linuxuprising.com/2018/06/… – Ben Campbell Mar 3 '19 at 16:51
  • I'm working on finding an answer but in the mean time, try plugging in a device to the headphone jack or unplugging and replugging the device to see if that refreshes things for you. I had a dell laptop that would switch to hdmi every time I would plug into and external monitor and would not show any other options until I would plug the headphones in or unplug and replug the headphones in. It seems you have another driver besides the intel one and I found some info but I have to work out some stuff. – mchid Mar 3 '19 at 23:10
  • Sorry for the delay. Please take a look here and see if these instructions work: wiki.archlinux.org/index.php/Acer_CB3-131_Chromebook – mchid Mar 12 '19 at 6:54
0

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1833116

git clone https://github.com/plbossart/UCM.git
cd UCM
cp -r chtmax98090/ /usr/share/alsa/ucm/
alsactl store

after reboot sound card should be detected

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.