0

I took my wife's computer today to do a fresh install of 18.04 LTS. (Her machine has 16.04.) First thing I did was get her to set a new password (of my choosing) so that I didn't have to keep running to her to enter the password while I worked to back up her stuff. At the same time I checked the box to allow logging in without the password. I restarted the machine, and now on reboot I am presented with a log-in box with a drop-down with her name, guest session and other. The Xubuntu task bar is there, but no whisker/start button, and I cannot dismiss the log-in dialogue or do anything else.

I've tried dropping down to the command line with Ctrl+Alt+F3, but neither her password nor the new password we set work with the "root" user or her full name ("Sue Smith").

How can we get back in so that I can back up her email and other data before I do a fresh install?

UPDATE:

So I am in recovery mode and have used passwd to ensure that her user's password is definitely set correctly, but I still can't get into the desktop for the same reasons described above. Since I am not being asked for a password, it's clearly not a matter of me entering the wrong password.

Is there something I can do on the command line -- a config file I can edit, or anything like that -- to reset things so that I am prompted for the password in the GUI, or so that I can log in without a password?

UPDATE 2:

I never was able to find a way to log back into the desktop, and searching around there have been other similar situations. I backed up the files to a USB drive on the command line, installed 18.04 and all is now good. (Well, it was for about 48 hours, until a recurring "system program problem" started appearing on each boot.)

That said, when changing the password in the GUI once I gave the machine back to my wife, I was presented with the same very confusing dialogue that I saw in 16.04 when I got her to change the password and at the same time select the option not to prompt for the password on log-in. This is it:

The system configuration has potentially changed.

When changing her password in 16.04 I answered "Yes" to this confusing question, and the result was that I could no longer log in as described above. What does the question mean? I made a change (the password) -- it wasn't "potentially changed", it really was changed! -- and "yes", I do want to "update [the] content", assuming that "content" is the password. And why will updating the content cause the loss of the content I'm trying to update?! In 18.04 I was presented with this again and answered "No", even though I have no idea what the question means, and the password was successfully changed and my wife can log into her machine with the her new password. But now I wonder if it's what caused the "system program problem" described above.

It's all so frustrating and seemingly unnecessary.

  • Sue Smith will almost certainly be the "full name" rather than the username that is required for command-line login (which will be a single word like sue or ssmith) – steeldriver Mar 3 at 0:44
  • @steeldriver Yes, which was half the reason I put it in quotes. On my own machine I know what my system user name is (eight characters, no space), but I never had a reason to note hers. – CraigH Mar 3 at 0:47
  • Well if you don't recall it, then the next option might be to boot into recovery mode from which you should be able to drop to a root shell without a password (unless you have set one for the root account) – steeldriver Mar 3 at 0:51
  • We did remember her log-in name (it's right there in the task bar, duh!) and neither password works with it. I guess I have no option except logging into recovery mode, as you suggest, and taking it from there. – CraigH Mar 3 at 1:26
  • I've added an update, but still stuck on the original problem. – CraigH Mar 3 at 7:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.