0

Ubuntu Audio Static Distortion [Intel 82801AA-ICH]

Audio: After a few minutes the audio output becomes static distorted, (System Wide with all Audio Applications VLC etc. But especially noticeable with YouTube’s Audio/Video playback), sounding as though something is causing it to be overdriven into what is called ‘Clipping’, (But even at low volume levels). If I click on the Volume Icon on the top right of the Ubuntu screen, and then click on the ‘Sound Settings’ item of that drop down menu below the Volume Slider, Opening the Sound Settings GUI, this seems to Temporarily resolve the Static as though doing this is resetting whatever is causing the Issue. In some instances, Muting and then unmuting the audio first, helps to ‘reset’ when opening the ‘Sound Settings’ GUI. But every few minutes the Issue returns. Forcing me to have to manually use the Drop down menu approach to clear up the distorted audio each and every time. Attempting to change levels and setting of alsamixer has no real effect on this issue, alsamixer has no ‘automute’ option in this instance. But opening the default Pulse Audio ‘Sound Settings’ GUI does. Whether the allow louder than 100 percent Check Box is unchecked or checked makes no difference in this behavior. However, this clearly indicates that the errant behavior is something associated with Pulse Audio.

32 Bit Ubuntu 16.04LTS Guest In VirtualBox 64 Bit Windows 10 Host (Windows Audio Drivers are NOT the issue). Motherboard: ASRock B250M Pro4-1B Rev 1.04

Result of: aplay -l **** List of PLAYBACK Hardware Devices **** card 0: I82801AAICH [Intel 82801AA-ICH], device 0: Intel ICH [Intel 82801AA-ICH] Subdevices: 0/1 Subdevice #0: subdevice #0

I attempted this “fix” ..In Terminal: sudo gedit /etc/pulse/default.pa and adding tsched=0 to load-module module-udev-detect so it becomes load-module module-udev-detect tsched=0 Save and Exit default.pa ..Pulse Audio can then be restarted in Terminal by: pulseaudio -k ..Doing this Did NOT solve the issue for me.

Next I attempted this “fix”: ...edit /etc/pulse/daemon.conf sudo -H gedit /etc/pulse/daemon.conf ..Find the line ; resample-method = speex-float-1 uncomment (remove the ;) and change to resample-method = src-sinc-best-quality ..Next: ; default-sample-rate = 44100 Should become: ; default-sample-rate = 48000 If the lines are not there at all, then add them. Reboot for changes to take effect.

I merely added the Uncommented Lines Below the ;Commented one’s, (to make undoing whatever doesn’t work easier).. ; resample-method = speex-float-1 resample-method = src-sinc-best-quality ; default-sample-rate = 44100 default-sample-rate = 48000 Then Rebooted for changes to take effect. ..Also Doing this Did NOT solve the issue for me.

So what is the Specific “Fix” that will actually work in this instance?

0

I believe I found an answer, for me. As it turns out, the issue seems to have been being caused by Virtualbox. Its sound setting was set to AC97. And That needed to be changed to IntelHD Audio. (The ability to do this will be grayed out if the Guest Operating System is still running).

Shut down the guest Linux OS. then use the Virtualbox Manager > Settings > Audio > and the drop down box to change the device to IntelHD Audio.

Then restart your Linux Guest, open alsamixer in a Terminal. At this point it will put a pop up noting the audio device has changed and will initialize the settings for the IntelHD Audio as device 0 (without having to use F6).

Then while in alsamixer, set your mixer settings as you would prefer. Then open a second Terminal. in that terminal type sudo su (to get root privileges) then your password. Then do "alsactl store" to save your alsamixer settings. Then close both terminals and restart your computer.

Now if you need to restore your saved Settings, in Terminal: sudo alsactl restore 0

I can't believe it took me this long to sort something this simple.

  • Question Author: DID NOT WORK: Describing the Specifics: It only took less than 30 minutes of testing before (Google owned Youtube) seemed to figure out there had been a “System driver change”: And once again began overdriving ‘AudioIPC Server’ into severe clipping and Static Sounding Audio Distortion beginning at around 4:30 into the playback of any Video longer than that in duration. – Snooper Mar 7 at 21:09
  • Continued: Which Automatic ‘Reset and Overdriving of System audio drivers’ (Pulse Audio and Alsa via Pulse Audio) into Severe Clipping and Distorted Static sound then periodically recurs every few minutes thereafter. (This has been, and still is, the issue all along. ‘AudioIPC Server’ shows up in Pulse Audio > Volume Control Icon (Top Right of GUI Screen) > Settings > Applications. When playing back Youtube videos). – Snooper Mar 7 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.