2

ctrl-alt-t opens a new window instead of a new tab while the shell is the active window. I see in the terminal shortcut settings --which are enabled-- (in terminal window: edit > preferences > shortcuts) that ctrl-alt-t is meant to open a new tab.

Prior to this issue I followed the instructions here to try to customize the shortcut, and I then followed the "rollback" directions in that post to undo it since it wasn't working. Maybe that's what messed things up for me?

Steps to create this issue:
1. open a gnome-shell terminal window
2. mouse click on the terminal to ensure it is active
3. ctrl-alt-t

Expected result: new terminal tab opens in existing window.
Observed result: new and separate terminal window opens.

gnome-shell --version is "GNOME Shell 3.28.3"

Edit: Here is a screenshot of the terminal shortcut page. I must have somehow changed the default ctrl-shift-tab to ctrl-alt-tab?

enter image description here

  • The answer you link is though probably the right one. Would you please try again to activate shortcuts in Gnome terminal, then close and re-open it to be sure that modifications are applied, and then add a screenshot of the shortcuts in your post? – FloT Mar 2 at 1:23
  • The default key to open a new tab is Ctrl+Shift+t (not Alt). With respect to Ctrl+Alt+Tab, this by default is a system wide hotkey to launch the terminal. Is your question really about the latter (I am confused since you say "ctrl-alt-t is meant to open a new tab.": no, its ctrl+shift+t). – vanadium Mar 2 at 8:46
0

The default hotkey in gnome-terminal to open a new tab is Ctrl+Shift+Tab. Probably, you did not properly reset that key to the default when reverting the change you made according to the question you linked to.

The behaviour where you see Ctrl+Alt+Tab opening a new terminal window, is perfectly normmal in a default Ubuntu install. That key combination is system wide defined to open a new terminal (see Settings - Keyboard).

To restore the default behaviour, change the assignment of the hotkey to open a new tab back to Shift+Ctrl+Tab in Nautilus preferences. Then you will have fully undone the changes you applied.

0

Dont mess with Ctrl and Shift

Open new terminal window: CtrlAltt
Open new tab in an active terminal window: CtrlShiftt

0

Silly mistake... turns out ctrl-alt-t was set as both the new terminal tab shortcut (in terminal preferences) and also the new terminal window shortcut (in keyboard preferences). I simply edited the terminal shortcut back to ctrl-shift-t.

Thanks all for the insights and sending me in the right direction!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.