4

I try to enable one finger scrolling in firefox ( it's more comfortable to scroll like that with a touchscreen). The default fedora version of firefox and chromium work like that.

I tried to launch firefox with the option MOZ_USE_XINPUT2=1 but it doesn't work.. Can you help me ??

  • It would help a little if you explain how you are trying to use MOZ_USE_XINPUT2=1, as in where did you place this command? – Charles Green Mar 2 '19 at 14:43
2

I had similar issues with the HP Pavilion x360. I found that MOZ_USE_XINPUT2=1 only works in Wayland, not Xorg. Furthermore, to make it a permanent solution I needed to follow these steps:

  1. open about:config in firefox to set dom.w3c_touch_events.enabled=1 (default is 2).

  2. edit /etc/security/pam_env.conf and add MOZ_USE_XINPUT2 DEFAULT=1

  3. reboot and restart firefox

See https://askubuntu.com/a/994483/799524

| improve this answer | |
1

I just might have the solution for you.

I was facing the exact same issue with Firefox where I could only scroll with two-fingers and single finger selected text.

After a lot of searching I found this Gentoo Wacom page mentioning that the Wacom driver has gesture emulation that causes a problem with Firefox and my Thinkpad X1 Yoga has a Wacom touchscreen.

The fix is to turn off the Wacom gesture setting by creating the following file:

/etc/X11/xorg.conf.d/50-wacom.conf

With this configuration:

Section "InputClass"
    Identifier "Wacom class"
    MatchProduct "Wacom|WACOM|Hanwang|PTK-540WL|ISDv4|ISD-V4|ISDV4"
    MatchDevicePath "/dev/input/event*"

    Driver "wacom"
    Option "Gesture" "off"
EndSection

Resart and enjoy :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.