3

So I was always a big fan of Ubuntu GNOME, and so was very stoked to see GNOME become the default interface manager for Ubuntu.

One of the things that has bugged me, and I seem to be unable to find the answer to, is that in prior versions of Ubuntu GNOME (before 18) the dock was always hidden by default, and one had to explicitly push the super key to show the hidden dock and access it's functionality.

Since Ubuntu 18 the dock is visible by default. Okay, so I activated the auto-hide setting. Although, the problem being that the functionality is different to before.

To be specific, when you have a multiple monitor setup, and the dock is on the middle or right monitor, with a monitor to the left, when you transition the mouse between the monitors, then the dock attempts to catch your mouse while it becomes visible.

This can be incredibly annoying because it grabs and removes mouse control (briefly) every time you cross over from the boundary of one monitor to another (with the dock in between).

There is an inability to control the settings specifically.

Some sort of setting to hide the dock, and do nothing on mouse over. Only show when the super key is pressed.

3

Since Ubuntu's dock is a fork of "Dash to Dock", it has the same configuration options. Editing them is just slightly more convoluted:

  1. Install dconf Editor, open it and navigate to /org/gnome/shell/extensions/dash-to-dock
  2. Enable intellihide
  3. Disable require-pressure-to-show
  4. Enjoy finally having a usable multi-monitor setup!
  • Note that even with animation-time set to 0, you may still need to make your cursor linger at low (very) speeds near the border between monitors before the dock will appear; it stays hidden when passing over it quickly. Unfortunately, I don't think there's a way to edit this speed-cutoff, which is annoying for sensitive mice. As stated in this answer you can use ctrl-Q to force it to show if it's being stubborn, without messing with the position of your other windows. – SeldomNeedy Sep 27 '19 at 20:28
0

One possible answer is to install the "Dash to Dock" plugin through the Software Center.

Then after "Dash to Dock" is installed and launched it is possible to access the plugin settings from right clicking on the applications icon on the new (identical looking) dock.

On the "Position and size" tab, enable "Intelligent autohide", and then open the Intelligent autohide customization window. Make sure the "Push to show: require pressure to show the dock" is disabled. (This disables the snagging)

Then I also enabled the "Dodge windows" settings, so that the dock shows on empty workspaces, and further replicates the original Ubuntu Gnome functionality.

Regards,

Note that it doesn't seem possible to just disable the default Dock from the "Tweaks" tool. Although after you have applied your new Dock settings through the "Dash to Dock" extension, you can disable it, and the new settings seem to apply just fine to the Original Dock.

  • Although it looks the original dock is still actually rendering underneath the new "Dash to Dock" that is visible. Not sure how to hide the original dock. – rcsandell Mar 2 '19 at 11:33
  • Running Dash to Dock along with the default Ubuntu Dock is not a good idea. – pomsky Mar 3 '19 at 11:52
  • Thanks, found and disabled the Default Dock extension under tweak tools. Will make an edit to the answer. – rcsandell Mar 3 '19 at 17:50
  • Seems like disabling the default Ubuntu Dock under with the "Tweaks" tool doesn't have any effect, although disabling the "Dask to Dock" with the "Tweaks" tool actually leaves the "Dash to Dock" settings applied to the default Ubuntu Dock, which is good enough for me. – rcsandell Mar 3 '19 at 18:14
  • Yes, because the default Ubuntu Dock is a pre-installed system extension: askubuntu.com/q/1030138/480481 – pomsky Mar 3 '19 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.