0

I'm running Ubuntu 18.04 with an NVIDIA RTX 2080, Kernel 4.15. I updated my packages, then manually switched the proprietary drivers from 410 to 418 (*) using the GUI switcher for proprietary drivers. Now I'm getting a black screen after login and nothing happens, even cannot switch to console using Ctrl-Alt-F1.

How can I switch back to 410 (or disable the driver) using the command line? ubuntu-drivers only shows a list, but for no reason doesn't allow to actually choose one of the drivers.

Or does anybody know the problem and know how to solve it?

(*) I've no idea if those came from the nvidia ppa or with CUDA or whatever in the past

  • sudo apt purge 'nvidia.*' if the driver has been installed using apt. But I don't see the 418 driver anywhere in repos or PPA. – Pilot6 Mar 1 at 14:39
  • The 418 driver was from the cuda repository. I've removed the cuda repository, purged and autoremoved everything. No chance to boot with any nvidia drivers. Using just the "ppa:graphics-drivers/ppa" (this is the main source for NVIDIA drivers, which everyone with a Turing GPU uses, right? Without this ppa, Ubuntu out of the box has just this nouveau driver or some generic whatever thing which gives me 1024x768?) sudo apt install nvidia-drivers-410 or nvidia-drivers-415 now lead to a black screen after login all the time. – Krangerich Mar 1 at 16:09
  • The official source of Nvidia drivers is the official repository of Ubuntu, not any PPA. But for RTX2080 and Ubuntu 18.04 PPA is the only option now I guess. You need 415, or 418 driver. 410 is no good for your card. – Pilot6 Mar 1 at 16:10
  • I'm looking at this ppa content to wait for the 2070 maxq release: launchpad.net/~graphics-drivers/+archive/ubuntu/ppa and no 418 yet. To fix your problem, maybe try moving the backup file (/etc/x11/xorg.conf_something_nvidia) to the original /etc/X11/xorg.conf – Mostrapotski Mar 1 at 16:17
0

I also had the same issue and the following fixed this blank screen after login for me without having to downgrade to 410 (tried it still failed)

The following link comes from Black screen after installing NVIDIA drivers 390, 410, 415 for GeForce 1050 TI, in particular, this answer: https://askubuntu.com/a/1105657/930120

You have to load the proprietary Nvidia drivers from initramfs.

/etc/initramfs-tools/modules

# List of modules that you want to include in your initramfs.
# They will be loaded at boot time in the order below.
#
# Syntax:  module_name [args ...]
#
# You must run update-initramfs(8) to effect this change.
#
# Examples:
#
# raid1
# sd_mod
nvidia
nvidia-drm
nvidia-modeset
nvidia-uvm

You could also check the content of /etc/modprobe.d/nvidia-graphics-drivers.conf, should be something like this:

options nvidia-drm modeset=1
blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off

Make sure to update initramfs. sudo update-initramfs -u -k all

To work around bug with still black screen on typing password, try the following: edit /etc/default/grub change the two lines to be like this:

GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

apply it with running sudo update-grub

Reboot, and hopefully enjoy!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.