1

I recently reinstalled Kubuntu and now when I want to install a software, I see this error:

Error I see

It happens when I want to install sublime or Emacs. I use Discover software center.


Update: Can you please tell me what packages should I check and what should I uncheck?

packages 1

packages 2

  • 1
    Your install medium is still defined as source for packages. As it is most likely not longer in the drive - accessing it fails. Remove the install-medium from your source list. Do that by running software-properties-gtk from terminal, jump to the second tab and disable the install-medium as source. – dufte Mar 1 at 7:07
  • @dufte sorry for hijacking, but seeing a gtk solution proposed in Kubuntu..I could not resist :-) – Bruni Mar 1 at 9:59
  • 1
    If things are still not working for you, please post the output of grep -Ev '(^#|^ *$|deb-src)' /etc/apt/sources.list /etc/apt/sources.list.d/*. – Justice for Monica Mar 3 at 17:21
  • @Bruni no problem ... my fault ;) – dufte Mar 4 at 9:13
2

As Dufte mentioned in his comment, your install medium is still defined as a source for packages (repository). As it is most likely not longer in the drive - accessing it fails.

To remove the install-medium from your source list, just go to settings in discover and untick the respective entry.

enter image description here

  • Can you please check the update i made in my question? (please check images I added and tell me what packages (sources) I should uncheck). – A. Hayati Mar 1 at 15:18
  • @A.Hayati Have you unchecked The one beginning with disc? (the seventh if I see corectly) – Bruni Mar 1 at 16:43
  • yes it's unchecked. – A. Hayati Mar 1 at 20:15
2

Run

SUDO_EDITOR=kate sudoedit /etc/apt/sources.list

Then comment out the line starting with:
deb cdrom ...
to be:
# deb cdrom ...
Save changes and exit.

Finally run sudo apt-get update

  • Can you please check the update i made in my question? (please check images I added and tell me what packages (sources) I should uncheck) – A. Hayati Mar 1 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.