I'm at my wits end here. This is my last effort before I go back to Windows.

I need to get nvidia-96 proprietary driver installed. Synaptic won't install it because it says it has dependencies. I installed every single dependency it listed except for "xorg-video-abi-10" which does not show up as an item that can be installed. I have no idea what to do. Using 11.10 with a NVIDIA Geforce 3 GPU.

Anyone know how to get this dang driver installed?

@fossfreedom: the opensource driver is extremely slow. So slow that the OS is unusable—words appear seconds after I type them—programs take forever to perform actions. Also it is causing my monitor to turn on and off for no reason.

@yossile: synaptic shows that I have xserver-xorg-core installed. And xserver-xorg-core-udeb does not show up as something that can be installed.

@papseddy: when I try to install the downloaded nvidia driver it says it won't work until I disable Nouveau kernel driver. I have tried everything to get this dang Nouveau kernel driver disabled. Nothing has been successful.

  • 1
    to be honest - that is such an old graphics card - the opensource drivers will probably be an equal or better than this old legacy nvidia driver. What are you trying to fix by installing this? Is this one of the drivers offered to be activated in the Additional Drivers window?
    – fossfreedom
    Mar 12, 2012 at 9:33
  • the fact that stuff appears very slowly can be due to other stuff. What specs is your PC (RAM, HDD size, Processor) - and also just to confirm the exact graphics card (lspci | grep VGA). Please edit all replies into your question. BTW I've now merge your two accounts.
    – fossfreedom
    Mar 12, 2012 at 15:52
  • possible duplicate of Why am I unable to install the Nvidia 96 driver?
    – Panther
    Mar 12, 2012 at 15:53
  • When I uninstalled the nouveau driver stuff trying to get proprietary installed, all the problems went away. Except now I have low resolution screen with low refresh. But when I try low res and low refresh with Nouveau it's still slow and still turning on/off monitor. So hope is nvidia will solve all this and give me a decent resolution.
    – Bob
    Mar 12, 2012 at 15:55
  • Okay, I guess bodhi solved this problem. It's a bug. I'll try installing 12.04 Beta and see if it's any better. If not, guess I'm back to Windows until this is fixed :( I'll report back after I get 12.04 up.
    – Bob
    Mar 12, 2012 at 15:58

6 Answers 6


I had the same problem on my xbmc box. I made a package that satisfied the xorg-video-abi-10 adn installed a file to tell xorg to ignore the abi mismatch.


it is a hack but it worked for me and hopefully it works for other people.

  • I followed diehard67 solution, and was able to install the nvidia-96 package. However, now when I boot my X it will be indefinitely changing between a black and a purple screen: seems like it is endless trying to retry to boot the X with no luck. As I read on the web it is possibly because the Xorg server that runs on 12.04 is not compatible with the drivers. diehard67, have you managed to make them work this way? Did you also downgrade your Xorg packages to the 11.10 versions?
    – user14374
    Sep 24, 2012 at 23:33

this worked for me: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-173/+bug/922268 see post 7. an xorg downgrade to 1.10 is done by following those instructions.

The 1.73 version of drivers has been updated by nvidia to work. lets hope they do that for the 96 vesion too!


Nvidia doesn't support too much for free OS like Ubuntu, you have to go to Nvidia site and find out your appropriate driver from there. When its downloaded, then follow below step. Might be help full for you.

  1. Make the run file executable: chmod +x /path/of/file.run

  2. Go to cli mode: ctrl+alt+f1 or f2)

  3. Stop your graphic service: service gdm/lightdm stop

  4. Run your *.run file: ./path/of/file.run

  5. Follow simple steps.

  6. Now start your graphic service or restart your system: service gdm/lightdm start

  7. Run this command to check which graphic card your system use: /usr/lib/nux/unity_support_test -p


In Natty the xorg-video-abi-10 is part of the packages xserver-xorg-core or xserver-xorg-core-udeb. Therefore, if you have/installed either or both you should have it and be able to continue with the nvidia-96 installation.


Found new versions of the drivers you require!

Just have a look at this link for them.

Hope it works.

  • Welcome to AskUbuntu. Can you provide detail about the link here please.
    – penreturns
    Oct 8, 2012 at 17:10
  • the link is dead Oct 1, 2015 at 11:30

In my case, Im using Linux Mint, but i guess that all repositories in this os is still the same as in Ubuntu, Using Linux Mint Maya (Ubuntu 12.04 equivalent in precise) I followed this forum


Since Nvidia-96 is not available on any higher versions (precise and upper i guess), in this forum, they tried to get the Nvidia package to a lower ubuntu version (oneiric) and use it to their current OS and downgrade their xorg to oneiric.

Now these steps are still working in my system, and I'm using oneiric nvidia-96.

  • 1
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – jokerdino
    Jun 9, 2012 at 16:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .