enter image description hereWell, it's very annoying, I have looking every where for a solution to get Virtualbox Windows 7 VM working on Xubuntu Kernel 4.4.0-143-generic , BUT NOWAY it not works !!! My solution was change the default kernel boot to 4.4.0-141-generic and it works fine. Of course it's a BUG, the kernel 4.4.0-143-generic can't find vboxdrv, when try to run modprobe vboxdrvit gives an error that the drive is missing, vboxusers is set correctly, the virtualbox KEYS are assigned correctly, I tried VB 5.138 which uses dkms then remove and purge it and install from Oracle webpage VB 6.04 which not uses dkms. So it's very frustrating. So, any comments that can help me run VB on -143-generic kernel ? thanks, Vladi

Attached image of VB log file under kernel -143

  • They all use dkms. What does sudo modprobe vboxdrv show?
    – Pilot6
    Feb 28, 2019 at 19:36
  • Did you install this one? download.virtualbox.org/virtualbox/6.0.4/…
    – Pilot6
    Feb 28, 2019 at 19:38
  • @Pilot6 Yes, I tried this VB version (6.0.4-12843), No success . I'm telling you it's a BUG, kernel -0141 generic works flawless but -0143-generic NOT, How staff from Ubuntu release a new kernel with this bug, do they can't compare a new build kernel with the preview one and check the differences before release ?? Mar 1, 2019 at 7:08
  • @vladimirpavloski could you please lower the current rant level and prepare bug report next time by yourself? I have reported bug and confirmed it (see my answer below). And what is even worse - you are using kernel from xenial-proposed, so it is not officially released (yet), but you requesting the full support of this package.
    – N0rbert
    Mar 1, 2019 at 9:16
  • It's not clear for me what didn't work. Additions should be installed not from Ubuntu repos but from the iso provided. Everything works fine for me.
    – Pilot6
    Mar 1, 2019 at 9:34

2 Answers 2


I have host with VirtualBox 5.1.38 and guest running Ubuntu 16.04.6 LTS with 4.4.0-143-generic kernel from xenial-proposed.

I can confirm that installing guest additions from virtualbox-guest-x11 APT package does not work. I have the following error message after login:

VBoxClient: Failed to connect to the VirtualBox kernel service, rc=VERR_ACCESS_DENIED

So I have reported bug 1818148 to LaunchPad.net. And I have discovered that 4.4.0-142-generic is also affected.

But installation from VBoxGuestAdditions_5.1.38.iso works on my guest system.
What is bad - this way is breaking recommendation given in similar Q&A before.

Update: the real bug is 1818049, it was reported on 2019-02-28 10:57:21 UTC.

  • 2
    I'm another confirmation. I rolled back just now to 4.4.0-142 and the problem went away. askubuntu.com/a/1127079/1698
    – Volomike
    Mar 20, 2019 at 1:49
  • @Volomike I did the same. That seems to be the only solution available currently.
    – Abhi
    Mar 25, 2019 at 6:50

This has been fixed in the test builds of VirtualBox but not yet in the releases (at the time of writing).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.