I have an external hard drive (Seagate Free Agent) that I normally download files to.

I have a dual boot Ubuntu 11.10 along with Windows 7-64 bit.

I can read all of my files in my external HD perfectly, but when I attempt to do a download of a file to this drive, I get an "unable to write because of read only" disk error. When I attempt to change the permissions of the disk through the "Properties" bar, I still get an error that I don't have the proper permissions to change permissions.

I have heard of "mounting" the disk, but I am afraid of mistakenly reformatting and destroying all the data that I have currently on that drive. How best should I safely change the permissions on that drive so that I can write and download files to the drive??

The drive is listed under /dev/sdc1.


I found the answer to my issue by opening a terminal and

sudo apt-get install ntfs-3g

Worked for me and restored my access to my USB stick.


type this on a terminal

gksu nautilus

¡¡¡WARNING!! be very cautious with this command its like super-god command.

it will open nautilus file manager, then go to the HDD and right click on the permissions tab and change the permissions; once done type


on the terminal and or close nautilus; remember to this ¡please!.

another thing that may help is to install this

sudo apt-get install ntfs-3g

and then reboot your machine.

  • 2
    Typing exit in the Terminal won't do anything while Nautilus is still running. – Eliah Kagan May 26 '12 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.