I'm trying to get my system setup for dual boot on 2 different SSDs on my system. One of the SSDs is an NVMe SSD. I can select and boot each one using the boot menu inside my BIOS, so the installations themselves are working as they should, but I can't seem to get this thing to dual boot at all.

With a bit of research, I found out about Boot-Repair and I installed and ran it. It kicked back

"GPT detected. Please create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag). This can be performed via tools such as Gparted. Then try again. Alternatively, you can retry after activating the [Separate /boot/efi partition:] option."

I opened up what I think is parted? (it's listed as "disks" on my installed software). But I have no idea what I'm supposed to be doing here so I was hoping someone could help me with step-by-step so I don't destroy my system.

Boot-Repair suggested I save my info and upload it to Pastebin when asking for help, which I did and it can be found below.


I am still unable to boot into Windows. Windows 10 (on /dev/nvme0n1p1) shows up now in the boot menu...

Advanced options for Ubuntu
Windows 10 (on /dev/nvme0n1p1)

...but when I select it, I get this purple error screen:

error: file `/boot/grub/x86_64-efi/ntfs.mod' not found.
error: no such device: 94487CA2487C8530.
error: can't find command `parttool'.
error: can't find command `drivemap'.
error: invalid EFI file path.

Press any key to continue..._
  • 1
    Run sudo update-grub on one of your systems and select it default in BIOS.
    – Pilot6
    Feb 27, 2019 at 4:28
  • sudo update-grub doesnt see it for some reason. I've even tried opening the windows drive in the file manager, then running os-prober, and then update-grub but it still doesn't see the drive. But thank you for the suggestion.
    – Cerebrix
    Feb 27, 2019 at 4:42
  • 1
    The problem is with MBR vs GPT and Legacy vs UEFI booting. I am sure someone will explain it in details. There is a few ways to fix it.
    – Pilot6
    Feb 27, 2019 at 4:44
  • You have new UEFI hardware and Windows installed in the now 35 year old BIOS/MBR configuration. That works and you can still use it. But you then installed Ubuntu in UEFI boot mode with a gpt partitioned drive. UEFI & BIOS are not compatible and you can only dual boot from your UEFI, not from grub. Once booting in one mode you cannot switch, just reboot. You can convert Ubuntu to BIOS boot just be adding a 1 or 2MB unformatted partition anywhere on drive and reinstalling the BIOS boot version of grub. Boot into live installer in BIOS mode, use gparted to add bios_grub & then Boot-Repair.
    – oldfred
    Feb 27, 2019 at 4:47
  • @oldfred Thank you so much for the reply. I feel like we're getting closer. I follwed your instructions, and I have grub now. But I am still unable to boot into windows. as you can see windows 10 shows up now i.imgur.com/LQrgwfi.jpg but when I select it, I get this i.imgur.com/WIfaBkt.jpg also here is the newer pastebin paste.ubuntu.com/p/j3ztp5fXxH
    – Cerebrix
    Feb 27, 2019 at 5:35

1 Answer 1


In the windows world and by default on linux, there are only two possibilities:

old: BIOS-MB + MBR-disk
new: EFI-MB + gpt-disk

However if you have an old motherboard and a new disk linux gives you a chance

You can use a gpt disk with a bios-MB The key thing there is that you need to create a BBP — a tiny 1MB special bios boot partition near the beginning of the disk. [Not to be confused by EFI partition or linux separate boot ]

You can do that with parted though I'd recommend gpt things to be done with gdisk.

If you prefer (g)parted, do the actual partitioning with gdisk and examination/mkfs etc with (g)parted. This keeps alignment well. Thereafter marking the type as BBP may be easier with (g)parted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .