1

Default terminal in Lubuntu 18.10 is QTerminal. Somehow, I couldn't find any setting for transparency anywhere.

I found almost similar question here. Lubuntu terminal background tranparency

Unfortunately, that's meant for LXterminal in Ubuntu 18.04.1 LTS.

Would it be possible to do that in Lubuntu 18.10's QTerminal? If yes, please let me know how.

If not, what is the alternative?

UPDATE

Found the setting as advised by DK Bose, but it didn't work.

enter image description here

  • I've edited the answer to mention the need for compositing and how to have Compton run via Autostart. Do let me know if your experience is different. – DK Bose Feb 27 at 3:55
2

It's there in File > Preferences:

QTerminal Transparency settings

And here's how it looks with 20%:

Example of QTerminal transparency


Edit:

  • I should have mentioned that compositing needs to be turned on for transparency effects to work. LXQt uses Compton because Openbox, the current window manager for Lubuntu 18.10, does not provide compositing by itself
  • To enable compositing automatically to survive a reboot or log out, click on Menu icon > Preferences > LXQt settings > Session Settings > Autostart > Add.
  • In Name, enter Compton
  • For the command, click in the blank box and then on Search. You'll be presented with a window showing items in /usr/bin where you need to scroll down to compton, highlight it, click Open, and then OK. Ensure that the check box next to Compton is filled.
  • Log out and log back in.

QTerminal should now show the desired transparency.

Editing your Compton preferences

  • You may notice that some of the "default" effects don't suit you.
  • To change them to what you like, click on Menu > Preferences > LXQt settings > Window Effects.
  • Make the changes you want in the GUI window that opens up.
  • I suggest not making changes in the Other tab unless you know what you're doing.
  • The changes you make are written to ~/.config/compton.conf So you need to log out and log back in for the changes to take effect or kill and restart Compton.
  • Thanks @DK, I tried that, didn't work. I've shared the screenshot on my updated question. – Sabrina Feb 26 at 13:28
  • 1
    Got it. Need to start Compton first at LXQt System Settings > Session Settings > Compton > Start it. It's not turn on by default. – Sabrina Feb 26 at 13:39

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.