0

Hello i tried to make an Ubuntu Virtual Server with 2 Network Adapters

In Virtual Box i added the First Network Adapter with NAT and the second Network Adapter with Host Only.

Now in Ubuntu i edited the "/etc/network/interfaces" to

auto lo
iface lo inet loopback 
auto enp0s3
iface enp0s3 inet dhcp
auto enp0s8
iface enp0s8 inet dhcp

when i now use "ifconfig -a" only enp0s3 has an ip address

what am i doing wrong so that enp0s8 will get an IP Address too?

1

The VirtualBox connected adaptor does not have DHCP enabled by default. You either need to statically assign an IP address or in the VirtualBox management interface turn on the DHCP assignment feature.

| improve this answer | |
  • In Host only Settings -> DHCP is activated – klausf11 Feb 25 '19 at 9:55
  • Did you assign an address range to the DHCP server in the VirtualBox manager interface? – Hmbl Stdnt Feb 25 '19 at 10:20
  • Its from 192.168.56.3 to 192.168.56.254 DHCP Server Adress: 192.168.56.2 – klausf11 Feb 25 '19 at 10:22
  • Do you have any vm's with working host only interfaces? – Hmbl Stdnt Feb 25 '19 at 10:24
  • No thats the only one. If i set the Host Only Network as 1 Adapter its working fine, but only the Host Only Adapter – klausf11 Feb 25 '19 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.