4

There is a problem with my camera. I used Ubuntu 16.04 and this OS could see my web camera. Then I changed my OS to Ubuntu 18.04 and now it doesn't see the web cam. What's the problem? I also tried both 16.04 and 18.04 liveCD and only the first one sees my web cam.

4.15.0-29-generic #31~16.04.1-Ubuntu SMP Wed Jul 18 08:54:04 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux works correctly with the camera.
4.15.0-45-generic #48-Ubuntu SMP Tue Jan 29 16:28:13 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux doesn't.

How to stay on Ubuntu 18.04 to use my camera? Any suggestions please? The OS determine my cam as Bus 002 Device 004: ID 0ac8:307b Z-Star Microelectronics Corp. USB 1.1 Webcam My cam is Canyon CNR-WCAM43G

There is a possibility that the developers did not include the old drivers for the new kernel version and IDK why. Skype and Cheese don't see the cam as well. I tried the commands cheese and cheese /dev/video0

    user@user1:~$ cheese

(cheese:5334): Gtk-WARNING **: 21:45:42.851: Theme parsing error: cheese.css:7:35: The style property GtkScrollbar:min-slider-length is deprecated and shouldn't be used anymore. It will be removed in a future version
** Message: 21:45:42.931: cheese-application.vala:211: Error during camera setup: No device found


(cheese:5334): cheese-CRITICAL **: 21:45:42.943: cheese_camera_device_get_name: assertion 'CHEESE_IS_CAMERA_DEVICE (device)' failed

(cheese:5334): GLib-CRITICAL **: 21:45:42.943: g_variant_new_string: assertion 'string != NULL' failed

(cheese:5334): GLib-CRITICAL **: 21:45:42.943: g_variant_ref_sink: assertion 'value != NULL' failed

(cheese:5334): GLib-GIO-CRITICAL **: 21:45:42.943: g_settings_schema_key_type_check: assertion 'value != NULL' failed

(cheese:5334): GLib-CRITICAL **: 21:45:42.943: g_variant_get_type_string: assertion 'value != NULL' failed

(cheese:5334): GLib-GIO-CRITICAL **: 21:45:42.943: g_settings_set_value: key 'camera' in 'org.gnome.Cheese' expects type 's', but a GVariant of type '(null)' was given

(cheese:5334): GLib-CRITICAL **: 21:45:42.943: g_variant_unref: assertion 'value != NULL' failed

** (cheese:5334): CRITICAL **: 21:45:42.943: cheese_preferences_dialog_setup_resolutions_for_device: assertion 'device != NULL' failed

    user@user1:~$ lsusb
Bus 002 Device 004: ID 8564:1000 Transcend Information, Inc. JetFlash
Bus 002 Device 003: ID 0ac8:307b Z-Star Microelectronics Corp. USB 1.1 Webcam
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
Bus 003 Device 002: ID 04d9:1702 Holtek Semiconductor, Inc. Keyboard LKS02
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    user@user1:~$ ls -ll /dev/video*
crw-rw-rw-+ 1 root video 81, 0 feb 25 09:48 /dev/video0

$ sudo modprobe -r gspca       
sudo: modprbe: command not found
$ sudo modprobe -r zc0301
modprobe: FATAL: Module zc0301 not found.
$ sudo modprobe gspca
modprobe: FATAL: Module gspca not found in directory /lib/modules/4.15.0-45-generic
1
  • What's the output of lsusb and ls-ll /dev/video* ? Please edit the question with that.
    – solsTiCe
    Feb 25 '19 at 9:45
1

A little search and I found this bug on lauchpad https://bugs.launchpad.net/ubuntu/+source/linux/+bug/144745

The proposed solution is to unload 2 modules and reload it

sudo modprobe -r gspca
sudo modprobe -r zc0301
sudo modprobe gspca

A permanent fix would then be to blacklist the zc0301 module. Create a file /etc/modprobe.d/blacklist-zc0301.conf with this content

blacklist zc0301
4
  • It is modprobe not modprbe ... I have edited the answer ...
    – Soren A
    Feb 25 '19 at 13:31
  • I did what you said. You can see the result in the OPost. Feb 25 '19 at 13:31
  • 2
    sudo modprobe -r gspca - modprobe: FATAL: Module gspca not found Feb 25 '19 at 13:32
  • Yes, I tried modprobe too. The module is not in the system Feb 25 '19 at 13:35
0

Try turning off Secure Boot. For my Dell laptop, I hold F2 while it's booting to enter BIOS. Then look around for the option to disable Secure Boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.