1

I have installed a dual boot of Ubuntu 18.10 and Windows 10.

Now when I start up my PC it goes directly to Windows 10. I have to click esc to abort the automatic startup and go to the GRUB options.

I want my PC to start up in GRUB so I can choose which OS to boot.

I have tested this process:

I have tried running this command in Ubuntu:

sudo update-grub2

and rebooted, but it didn't work. The terminal says that if it didn't work I should post this URL:

http://paste.ubuntu.com/p/VKW6QVyZWD/

What should I do

First 15 lines of /etc/default/grub

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
#GRUB_HIDDEN_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

When I run the command, grep -A3 -B1 timeout /boot/grub/grub.cfg I get:

/boot/grub/grub.cfg-if [ "${recordfail}" = 1 ] ; then
/boot/grub/grub.cfg:  set timeout=30
/boot/grub/grub.cfg-else
/boot/grub/grub.cfg:  if [ x$feature_timeout_style = xy ] ; then
/boot/grub/grub.cfg:    set timeout_style=menu
/boot/grub/grub.cfg:    set timeout=10
/boot/grub/grub.cfg:  # Fallback normal timeout code in case the timeout_style feature is
/boot/grub/grub.cfg-  # unavailable.
/boot/grub/grub.cfg-  else
/boot/grub/grub.cfg:    set timeout=10
/boot/grub/grub.cfg-  fi
/boot/grub/grub.cfg-fi
/boot/grub/grub.cfg-### END /etc/grub.d/00_header ###
--
/boot/grub/grub.cfg-}
/boot/grub/grub.cfg:set timeout_style=menu
/boot/grub/grub.cfg:if [ "${timeout}" = 0 ]; then
/boot/grub/grub.cfg:  set timeout=10
/boot/grub/grub.cfg-fi
/boot/grub/grub.cfg-### END /etc/grub.d/30_os-prober ###
/boot/grub/grub.cfg-
grep: –: No existe el archivo o el directorio
grep: Paul: No existe el archivo o el directorio
grep: Benson: No existe el archivo o el directorio
grep: 2: No existe el archivo o el directorio
grep: hours: No existe el archivo o el directorio
grep: ago: No existe el archivo o el directorio

Thanks!

  • Report in lines 599 thru 630 show your issue. Grub only boots working Windows, or Windows that is not hibernated. And Windows fast start up sets the hibernation flag. See askubuntu.com/questions/843153/… – oldfred Feb 24 '19 at 18:42
  • I have already changed the fast startup mode. – joseto dominguez Feb 24 '19 at 18:55
  • And it doesn't work – joseto dominguez Feb 24 '19 at 19:04
  • Please edit your question and describe how the system works now and what do you expect. – Pilot6 Feb 27 '19 at 3:07
0

If you want GRUB menu to be shown at startup, then comment out

GRUB_TIMEOUT_STYLE=hidden

to be

#GRUB_TIMEOUT_STYLE=hidden

to /etc/default/grub, then run

sudo update-grub
  • It's already set at 10 seconds, according to grub.cfg in pastebin. – Paul Benson Feb 24 '19 at 16:56
  • Why not simply do it? – Pilot6 Feb 24 '19 at 16:59
  • Yeah, is says this: GRUB_TIMEOUT_STYLE=hidden GRUB_TIMEOUT=10 So I asume its already set at 10 seconds – joseto dominguez Feb 24 '19 at 17:07
  • Can you see the difference between GRUB_TIMEOUT=10 and GRUB_HIDDEN_TIMEOUT=10? – Pilot6 Feb 24 '19 at 17:10
  • I tried this, and didn't worked. Should I delete the GRUB_TIMEOUT=10 line? – joseto dominguez Feb 24 '19 at 17:21
0

There's one more solution for this:

Boot into Windows and download easybcd application and then run it as an administrator.

Make an Ubuntu entry in easybcd and then add that entry with Windows in edit boot menu.

Uncheck skip boot menu option.

Then test it whether it works, and if not then repair boot files through it making sure that Ubuntu entry is still alongside the Windows entry.

For detailed steps see the section of this YouTube video from 9:16 minutes to 10:00.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.