2

I have tried to change the terminal by either using the GUI:

Preferences -> LXQT Settings -> Session Settings -> Default Applications -> Terminal Emulation

or using the terminal with the following code:

sudo update-alternatives --config x-terminal-emulator

But I have had no luck changing the default terminal of my Lubuntu device.
Any ideas how could I change it?
I don't like the appearance of the current terminal.

  • How are you starting the terminal? – Organic Marble Feb 23 '19 at 21:50
  • @OrganicMarble using Ctrl + Alt + T. – Farhood ET Feb 24 '19 at 6:59
  • Working fine in Xubuntu – Indacochea Wachín Aug 8 '19 at 16:14
2

There isn't a single setting for this yet. However if you change them all to x-terminal-emulator, which is a symlink, you can then later easily change them all at once by using update-alternatives as you already tried.

To change the global shortcut key's terminal:

Open Preferences > LXQT Settings > Shortcut Keys and double click on the item that has the shortcut you wish to change.

Global Actions Manager window

And edit the command.

Edit Action dialog

To change terminal used by PCManFM-Qt, (file manager and desktop):

From the PCManFM-Qt File Manager menu open Edit > Preferences and select the Advanced tab, and Terminal Emulator field.

Advanced tab of PCManFM-Qt preferences dialog

Default for terminal based programs (.desktop files with Terminal=true):

Run from lxqt-panel (panel and menu):

Set by Preferences > LXQT Settings > Session Settings, Default Applications tab, and Terminal Emulation field.

LXQT Session Settings Window

Run from PCManFM-Qt (file manager and desktop)

Always xterm in Lubuntu 18.10!

Should use PCManFM-Qt settings, and has been fixed for 19.04.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.